BMW Forums : BimmerForums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,
I have 2012 BMW X5 225KW'd disel, If im driving on highway something around ~90KM/H and there will be small ascent and then it happens "engine malfunction - reduced power" warning light just flashes for few seconds and disappears. When i accelerate and dont drive slowly it won't happen. Does someone have had same issue? What should i check?
I had problems with Particulate Filter but they programmed it out..
 

·
Registered
Joined
·
1 Posts
X5 3.0D in limp mode

Had this problem with not revving above 3000rpm and no acceleration, with no messages on dash, my OBD2 not reading as car is 2002!!!! So after reading several forums it looked like it may by the MAF, so disconnected it and no difference!! so I purchased a new Bosch fuel filter and air filter (£57 from ECP) fitted the fuel filter first as is the easiest, then tried it and it works fine now so then fitted the air filter and although the car has done 123500 miles it feels like new again!
 

·
Registered
Joined
·
1 Posts
Hello,
I have 2012 BMW X5 225KW'd disel, If im driving on highway something around ~90KM/H and there will be small ascent and then it happens "engine malfunction - reduced power" warning light just flashes for few seconds and disappears. When i accelerate and dont drive slowly it won't happen. Does someone have had same issue? What should i check?
I had problems with Particulate Filter but they programmed it out..
Did you get this fixed??
 
1 - 5 of 5 Posts
Top