BMW Forums : BimmerForums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Just when I need my windscreen demister it starts playing up.

Fired up the car this morning and as usual, switched on the button (top rhs of the heating panel) for the heat to go direct to the windscreen at maximum speed, however this time it did very little and only blew very slowly. I played about switching on the A/c etc but it didn’t make any difference. After 5-10mins the fan jumped into full speed then slowed down again.

I stopped the car for an hour or so then when I stared it the fan was blowing at full speed to the windscreen as normal, again when I switched the system to auto then tried to get max speed to the windscreen it wouldn’t work.

Any Ideas of whats wrong would be appreciated
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #2 ·
Found the following on a problem page

Lower Front Wheel Well Liners

Plastic liner in forward part of wheel well which is easily broken by contact with curb or concrete parking stops, but is fairly inexpensive. The passenger's side liner shields the secondary air pump from water and road debris. If it is missing water can get into the pump, damaging the bearings and requiring replacement.

Is this secondary air pump associated with the fan in question as my wheel liner is broken at the bottom
 

·
Registered
Joined
·
20,393 Posts
Found the following on a problem page

Lower Front Wheel Well Liners

Plastic liner in forward part of wheel well which is easily broken by contact with curb or concrete parking stops, but is fairly inexpensive. The passenger's side liner shields the secondary air pump from water and road debris. If it is missing water can get into the pump, damaging the bearings and requiring replacement.

Is this secondary air pump associated with the fan in question as my wheel liner is broken at the bottom
No, that is to do with the engine/catalytic converter warm up :)

If the fan speed has a mind of it's own no matter where the setting and the dash display stays on all the time and doesn't flicker then you most likely need a new Final Stage Resistor, :thumbsup

Have a a search on here for Final Stage Resistor, be mentioned several times
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #4 ·
Thanks Ronnie, the cars still under warranty so will get it sorted along with the parking sensors which seem to be playing up.
 
1 - 4 of 4 Posts
Top