BMW Forums : BimmerForums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hello ! I also have a problem. Until now, my driveshaft vibrated quite badly, especially in 2nd gear at 2500 rpm (40km / h), but not only. Today I went to the mechanic, I took off the driveshaft, it was checked not to have play in the crosses, to have the balancing plates. I changed the driveshaft bearing and the drive shaft guilbo (both on car was being OEM, cracked and hardened). I put on some new FEBI, after i hit the road. I mean 99% of the problems are gone (no more rumbling, no more beating) but sometimes the driveshaft vibrates very easy and this is rarely , not every time (it doesn't feel so bad anymore, almost imperceptible and no longer rumbles / beats), is feel in 2nd gear at the same rotations and the same speed . What else to check ? is it possible that the bearing is already bad from factory? All CV and engine pads are ok! Any ideas what it might be?

Thank you !
 

·
Registered
Joined
·
862 Posts
Gearbox or diff support bushes?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
All is ok (the bushes) . And now is vibrating like first Time... Very hard...
 

·
Registered
Joined
·
3,106 Posts
you did replace the centering bush yeh,,,easily forgotton,,its a cheap part,,goes inside prop end when its apart,,only£7 but needs done,,mine looked fine but did it anyway,,well garage did,but i watched when they did it,,had guibo and new bolts and centre bearing also,,,also you did get new bolts for the guibo?,they are not to e used again
 

·
Registered
Joined
·
3,106 Posts
mmmmm..im at a loss .maybe the other end of prop..has another sort of flex disc,,or even maybe the bolts not correctly torqued,,and for febi,,my drop link failed after 8 month's,,i thought it was summit else,,but nope drop link was shot,,all new suspension parts febi from auto doc etc,,my guibo that i fitted was also febi and that was fine as for all the parts on my e90 suspension,,the prop etc was on my old e46 which i sold 2 years ago
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
The guibo is the same as the original, it is made in Germany. I saw that he tightened the guibo .... Anyway, I don't understand how some bolts good fix can cause you problems ... I think I should go to the service dealership, but even there I have chances not to discover anything, and pay a lot of money.
 

·
Registered
Joined
·
439 Posts
Where do you feel the vibrations? When a bolt snapped on my propshaft it vibrated the whole front including door cards and I think being an automatic if I let go of the accelerator it would stop the vibrating regardless of speed which is how you could differentiate it being the propshaft to something like wheels/bearings.

If you feel vibrating in mainly the steering and pedals then it's going to be something on the front end

Another possibility is, have you checked that one of your engine mounts haven't failed, on the e90 330d you can grab the intake manifold and give it a good shake to see if there's any obviose play

Sent from my SM-G955F using Tapatalk
 

·
Registered
Joined
·
13 Posts
Discussion Starter #10
Hi, thanks for the reply. I feel the vibrations in the steering wheel (no vibration in pads, and the bad thing is not vibrating all the time...but in 90% is do ) , the gearshift, and it's like a sound from behind. Sometimes when I go with her on the long road, at high rpm , she vibrates a when I leave a little of the acceleration . I can't shake the engine by pulling the intake, is ok all mounts. All bolts from drive shaft is ok
 

·
Registered
Joined
·
3,106 Posts
id also check calipers,,,especially if it's not 100 % of the time,,binding calipers can have very bad vibrations..ive experienced it a few times
 

·
Registered
Joined
·
13 Posts
Discussion Starter #13
I have recheck the engine mounts and is ok. I will go to the dealership next week and i pray to found the problem 😂. I will post here what they found.
 

·
Registered
Joined
·
439 Posts
I have recheck the engine mounts and is ok. I will go to the dealership next week and i pray to found the problem . I will post here what they found.
I hate going to Dealerships, two BMW specialists I've been to are dodgy cons and on my e90 330D I swear half the stuff I do costs less or equal to an hours labour half the time lol.

That said, this is the problem with forums, we have to imagine the problem based on your description and we can only throw some assumptions out. What may help a little is if you did a video, drive the car and make it vibrate, try to stop making it vibrate as well if possible by doing some things like lowering speed, putting in clutch (if you have one), accelerate more and see if it just gets worse and worse or if it stops after a certain speed.

Maybe someone may familiarise with the sound or maybe some of those things you do while driving may give us some more ideas of what it may be.

Sent from my SM-G955F using Tapatalk
 

·
Registered
Joined
·
13 Posts
Discussion Starter #15
I hate to go to the dealership too, but the mechanics I know are too lazy and want to get away as easily as possible. The problem is that it doesn't make any sound when it vibrates, after I changed the intermediate bearing. Sometimes the vibration is felt on the Stationary with and without the clutch pressed. But it doesn't always do, that's the problem, but in a 20-minute journey it will surely vibrate. The vibration is not felt in the pedals, it was in the shifter and in the steering wheel.
 

·
Registered
Joined
·
3,106 Posts
only other thing is maybe prop centre bearing,,when mine went the gearstick would jump around and the whole car vibrate,,but would not really go past 25 mph without vibrating so much it was impossible to drive,,maybe it;s on its way out,,but if you have done the flex disc you will have checked the centre bearing
 

·
Registered
Joined
·
13 Posts
Discussion Starter #17
only other thing is maybe prop centre bearing,,when mine went the gearstick would jump around and the whole car vibrate,,but would not really go past 25 mph without vibrating so much it was impossible to drive,,maybe it;s on its way out,,but if you have done the flex disc you will have checked the centre bearing
But i have replace the centre bearing... With a new one from Febi made in Germany, like the guibo.
 

·
Registered
Joined
·
319 Posts
When you had the prop off did you check the condition of the gearbox output and rear diff input bearings? The flanges should not have any movement other than rotation, if they move at all up/down left/right, they need replacing.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #19
When you had the prop off did you check the condition of the gearbox output and rear diff input bearings? The flanges should not have any movement other than rotation, if they move at all up/down left/right, they need replacing.
I the drive shaft is strong în positions. No movement from Gearbox and no movement diff. Only rotation.... Also the exhaust is ok.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #20
Update : After dealership :they say all is good, and don't know what is have. They say is normaly because is an old car and let it go... I'm verry angry because it was go 90 euros from my pocket for nothing... For a car wash (is free ).
 
1 - 20 of 22 Posts
Top