BMW Forums : BimmerForums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter · #1 ·
Hi all need some advice
I have bmw 320eds on 2016,with 64k has fsh
It recently developed what I can only call as a very small/minimal hesitation this happens only very occasionally and only happens when I take my foot on the accelerater and put it back on it last for not even a second it's over as quick as it comes car pulls and runs fine all of the time otherwise
It maybe nothing but would appreciate any ideas anyone may have
Many thanks
Darren

Sent from my SM-G975F using Tapatalk
 

·
Registered
2013 F11 503d
Joined
·
312 Posts
Just seeing this now, sorry.
It could be a multitude of things really but with things like this I usually go around the engine sensors and throttle body and clean them. This would include the MAF,MAP, intake/exhaust camshaft solenoids, throttle body and injectors (depending on petrol or diesel) and reset adaptations. A fuel treatment and fuel filter change also wouldn't hurt. Its not expensive and only takes time and if it doesn't work, at least you know they have been done.
Start with that and see what happens, if it doesn't work report back and we'll try help more.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #6 ·
Great thanks for the help I have put diesal treatment in I will get some maf cleaner and also check the other items u mentioned and report back
Many thanks


Sent from my SM-G975F using Tapatalk
 

·
Registered
Joined
·
1,370 Posts
These are a real pain to track down as they usually end up having to develop to a point where they trip a fault code.

I had something similar on my E46 330d - ultimately transpired to be a MAP sensor on the way out but took a long time to throw a code.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #8 ·
Thanks for that had a similar issue years ago on an rx8
It's annoying more than anything as said car runs fine it's only every now and then this happens but does bugger me
As you said if it throws a code be much easier
Thanka for the input
I try all as mentioned above hopefully may solve the issue.

Sent from my SM-G975F using Tapatalk
 

·
Registered
Joined
·
1,370 Posts
If you've got something that can read live data that can sometimes help - eg if you can see fuel feed pressure fluctuations or 'odd' manifold pressure blips etc whilst driving.

Good luck and keep us posted!
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #10 ·
Will keep this updated and once solved will post as may help others who may have/get similar problems

I was thinking of getting myself something like a carry could u tell me do they read live data or would I need something a little more sophisticated

Sent from my SM-G975F using Tapatalk
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #11 ·
Will keep this updated and once solved will post as may help others who may have/get similar problems

I was thinking of getting myself something like a carly could u tell me do they read live data or would I need something a little more sophisticated

Sent from my SM-G975F using Tapatalk


Sent from my SM-G975F using Tapatalk
 

·
Registered
Joined
·
1,370 Posts
Ideally the BMW software on a laptop - whichever one is relevant to 2016. Used to be INPA, but I think it's different on the newer cars.

I've got a an iCarsoft pro for my newer cars which does quite a lot of live data but nothing has the depth and breadth of the BMW stuff that i have for the older ones.
 

·
Registered
Joined
·
75 Posts
Discussion Starter · #14 ·
Update
I cleaned the maf and map sensor the map sensor was a little clogged up with suet/carbon deposits
Haven't had chance to give the car much of drive but will take it out tomorrow see if that has helped/solved problem

Sent from my SM-G975F using Tapatalk
 
1 - 14 of 14 Posts
Top