BMW Forums : BimmerForums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
My 2014 X1 (E84) Professional Radio has poor reception across all bands AM, FM, DAB. (No GPS/Nav fitted)

Confused of where the Antenna is actually located, some say its in the rear tailgate window and many say other locations.
Some say the Diversity Antenna Amplifier in the tailgate is the problem as it can get wet etc. But this is in the interior/inside of the tailgate not exposed to the elements and is totally dry.
I have a Fin on the roof which is not a dummy as it has wiring attached.

I have searched and searched Google/YouTube for info of how test the antenna circuit/amplifier whether its in the defrosting grid or Fin. Or even if the amplifier if is at fault could be by-passed.

So anyone know of where/how etc.......
 

·
Registered
Joined
·
11 Posts
Discussion Starter #3
OK,
All sorted.......

Found a post about the secret menu for the radio.

First I removed the rear panel to access the Amplifier and its connections and disconnected the cables and ribbon.

With a volt meter set at lowest Ohms/alarm and checked from pin to aerial grid testing continuity. The cleaned all the terminals with contact cleaner and refitted.

Using the menu to check various settings and changed some.

FM/AM was fine searching and finding all local stations. But DAB was no better.
But using the normal procedure as on my previous cars, just press search and that finds all the stations. But not BMW.......
Had to go to Astore list to select National network etc and find the local stations and store them where ever you want them.

And now the radio is sorted, just abit arse backwards searching for your DAB stations compared to all my previous cars.
 
1 - 4 of 4 Posts
Top