BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Bit of a heart stopper;

Autobahn 240 kph, uphill, slight judder then no power, rev’s at 0. No reaction from accelerator, Electrics OK, hazards on and drift to hard shoulder.

Attempt a re-start, engine starts, then stops. Time to abandon the car, lock and unlock, attempt a re-start - engine fires up as normal. Drives OK, no lack of power running smoothly. Heart rate returns to normal.

I can’t think of anything, serviced within 500 miles.

Could be mucky fuel, brimmed at last fill.
Surely not a third DPF.

Any ideas gratefully received.

Thanks
 

·
Super Moderator
Joined
·
3,352 Posts
You need codes read. One possibility piezo injector starting to fail and shorting internally.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Hi,
Thanks for your reply, all I got from my “service partner” was no idea, never heard of this happening before.

Thanks
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Hi,
No drive train warning, just an engine stutter then no power, free wheel to the hard shoulder.

Had a second EGR about 4000 miles ago on the back of a message from our fleet manager, slow loss of coolant from a 320d, car went up in flames. I passed the email to my local BMW dealership as I’d had a low coolant warning. EGR instantly replaced.

Mystery. I’ll try and extract any fault code readings from BMW.

Thanks.
 

·
Registered
Joined
·
488 Posts
EGR faults don't always throw up any codes. This sounds to me like it's your EGR again, but the lack of a drivetrain warning is weird.

Sent from my SM-G973F using Tapatalk
 
1 - 7 of 7 Posts
Top