BMW Forums : BimmerForums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
42 Posts
Discussion Starter · #1 ·
hi all recently Purchased a 2000 bmw 328 ci , fancied something different after my astra coupe , and the difference in the drive is amazing , so smooth and comfy

has a few cool factory extras , rear power blind , upgraded speakers , nappa full lather ,

also comes with

auto dim mirror
rain sensitive wipers
pop out headlight washers
memory seats and mirrors
cruise control

Most of these are proberly standard but still nice to have

Now the bad bit , only had it a week or so but noticed the last few days when the engine is cold the revs dip every so often and almost stall , and it stalled a few times at junctions , abit more reading into it , i disconnected the vanos solenoid , and it idles better at cold , no dip in the revs , also seems to be holding back on power

cars serviced recently ( last three months )

so I've ordered the Vanos seal replacement kit off ebay , so hoping to do this my self once it arrives
http://www.ebay.co.uk/itm/1508031093...84.m1497.l2649

is there any other area i should be checking , thank you all

Also been told to take the oil cap off while its running , pop a bit of plastic sheet over the hole and see if it pulls it in , well i did this and it tried to pull it in , is this an indication of a air leak

Thanks all
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #2 ·
Went to get codes read today as I found a local specialist , came up with inlet cam position sensor

Didnt expect that , or think these symptoms were related , will have to get one on order
 

·
Registered
Joined
·
42 Posts
Discussion Starter · #3 ·
replaced this , car drives fine now , but still has idle issues when cold , will have to try the vanos seals next
 
1 - 3 of 3 Posts
Top