BMW Forums : BimmerForums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi I have a 730 7 series. I hooked it up to a trickle charger a few months ago and tried to start it today. When I press the start button I get a 'pre-heating please wait' message which goes out after 10 seconds, but then nothing happens. When I press the start stop button again, the car just closes down as if it was running. All other electronics seem to be working fine. Any thoughts?
 

·
Registered
Joined
·
53 Posts
Hi I have a 730 7 series. I hooked it up to a trickle charger a few months ago and tried to start it today. When I press the start button I get a 'pre-heating please wait' message which goes out after 10 seconds, but then nothing happens. When I press the start stop button again, the car just closes down as if it was running. All other electronics seem to be working fine. Any thoughts?
Happens to me and I'm not entirely sure what it is that I need to work out. I've tried holding the button for a bit longer. Foot on and off the brake.
I try a few times and then somehow get it going. Only happens in real cold though
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
no, not completely flat, but of course its only a trickle charger and it is possible that, especially during the cold weather, the trickle charge was not sufficient to improve the battery
 

·
Registered
Joined
·
2,668 Posts
Could well be the battery is finished.
The cold/frost will kill an ageing tired battery and charging won't put the Amps back.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
I put a voltmeter across the battery and it showed 13 v, so the trickle charger worked fine keeping the battery topped up. The next day I pressed the starter and she fired up as if nothing was wrong! I hate these sorts of faults!!
 
1 - 8 of 8 Posts
Top