BMW Forums : BimmerForums banner
1 - 9 of 9 Posts

·
Registered
BMW X5 E53
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi guys i have a 2000 x5 3.ol diesel sport, for about 6 months now iv had a problem where i start the car no problem can drive half a mile or 100 miles turn the car off and it wont restart but its only happened 3 times in that 6 months theres no warning it drives great its unpredictable when its going to happen its always after the car has been driven and not from cold iv had the fuel pipe off the filter and the pump is working it cranks over fine but doesnt fire iv had the rac out twice the 1st one plugged it in checked everything and said its not immobiliser but matybe the crank sensor and the egr valve isnt returning to zero it stays on 6 per cent the 2nd guy that came out said its none of the above its the fuel pump but the car restarts after an hour or 2 of sitting there then it may not happen again for a few weeks or months has anybody come across this before thanks kevin.
 

·
Registered
BMW X5 E53
Joined
·
6 Posts
Discussion Starter · #5 ·
So what are the symptoms of a faulty camshaft sensor? I have changed the crank sensor and egr valve yesterday but today it happened again it only took 10 minutes before it started but same again cranking but not firing its getting fuel to the injectors but is there anything that would shut the injectors down like another sensor or maybe the fuel rail its really annoying not knowing when or if it will happen thanks
 

·
Registered
Joined
·
6,729 Posts
I had a wire short on the injector wiring once.
It was only by chance i found it and it hadn't rubbed enough for me to see the actual wire but enough to short on the injector pipe.
It was at the back where they sort of turn.
 

·
Registered
BMW X5 E53
Joined
·
6 Posts
Discussion Starter · #7 ·
I had a wire short on the injector wiring once.
It was only by chance i found it and it hadn't rubbed enough for me to see the actual wire but enough to short on the injector pipe.
It was at the back where they sort of turn.
Would that stop the car starting though on just 1 injector or just make it run rough
 

·
Registered
BMW X5 E53
Joined
·
6 Posts
Discussion Starter · #9 ·
Hi guys just to let you know the fault is now cured it was the camshaft sensor with an intermittent fault. So after changing the crank sensor egr valve all the injector spill pipes its actually fixed thanks for the replys and to the guy who actually said cam sensor.
 
1 - 9 of 9 Posts
Top