BMW Forums : BimmerForums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Hi!
So I went to the mall, parked my car went back tried starting it, the lights came on the dash tried to start the ignition. Then everything turned off, no lights, no locks nothing. The dash even froze, any ideas?
320d
274426
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #3 ·
Dead battery?
Seems like that currently yes, going to let you know tomorrow. It just surprised me, because i legit drove that 5mins before this and it worked well - start up was nice etc and suddenly no power, normally it would take some time to the drain the battery so fast, no?
 

·
Registered
Joined
·
854 Posts
Seems like that currently yes, going to let you know tomorrow. It just surprised me, because i legit drove that 5mins before this and it worked well - start up was nice etc and suddenly no power, normally it would take some time to the drain the battery so fast, no?
Yes, normally you get some warning ... but todays electronics prefer to just shut down in case of permanent damage I guess.

BMW (and others) could make diagnosis, especially of the simple 'home repairable' things like a dead battery, a lot easier and a lot more relevant to customer needs, rather than wanting it taken back to main dealer to make even more money.
 

·
Registered
Joined
·
159 Posts
Check the blower fan turns off when switch ignition off. If the blower is wobbling at max speed it's the final resistor pack which the solenoid doesn't release so just keeps blowing and drains the battery.
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #8 ·
Forgot to update this, well yup it was a bad battery, the battery was an old 2013 benz battery, had it tested also, didnt really hold a charge. Had problems with the altenator in the past - got that fixed.
Check the blower fan turns off when switch ignition off. If the blower is wobbling at max speed it's the final resistor pack which the solenoid doesn't release so just keeps blowing and drains the battery.
Literally had this problem a few weeks back, was a really easy fix :D
 
1 - 9 of 9 Posts
Top