BMW Forums : BimmerForums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
0 Posts
Discussion Starter · #1 ·
Hi all, just joined up and wanted to say hi to all. I am after some help and advice, so please bare with the lengthy post. Please read on.

I have a E36 325i saloon, 1993 L reg. It has a genuine 46k on the clock and is immaculate inside.

The engine is where I am after a bit of help and advice on. I bought the car as a non-runner as the previous owner had cooked the lump. 2 of the pistons had holes in them, and the head was fryed beyond belief. He had driven the car hard, for approx 50 miles, without the rad cap on!!!

Anyhow, I bought the car cheap and managed to source an engine. When purchasing the engine, I was assured it was a 325i single vanos lump but when we got round to fitting it, realised it was a 5 series lump. The sump was in the wrong place, highlighting it was an E34 engine. Also, it had 2.0 embossed on the head, making us believe it was a 520i engine.

The supplier was adament that it was a 2.5 engine, and wouldn't budge, so we decided to use it anyway. Swapped over everything useale from the scrap engine to the newly acquired one. Sump, starter motor, alternator, coil packs, throttle etc. . . ..

Started fine, and is still running good and strong. Although it feels a little held back at times. Do I need to get a remap or chip to get it all singing and dancing properly??? I don't want to give up on the car, I love it too much!!!!

Please help!!
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #3 ·
Hi, yeah sorry for posting here. I wasn't too sure which would be the best forum to post this in, so I do apologise. Will have a hunt around and get it moved.

Cheers.
 

·
Registered
Joined
·
20,393 Posts
Hi sandip-sangar, welcome to Bimmerforums UK, :thumbsup

Will have been a e34 engine for sure, the sump sits at the front on them rather than back :hihi
 

·
Registered
Joined
·
0 Posts
Discussion Starter · #6 ·
Well the engine is running fine, and has been for nearly a year. I just get the feeling all in not working as it should. Would a remap or chip do the trick?
 

·
Registered
Joined
·
2,255 Posts
The 2.0ltr engines aren't really that powerfull, but if its holding back, its usually more to do with the likes of fouling injectors, intermittent engien sensors etc.
 
1 - 9 of 9 Posts
Top