BMW Forums : BimmerForums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi. This is my first post.
I have an 520d BMW E60 (2006) and never had any problems with it since I bought it a year ago. But having been away (buying my wife her new car) my wife drove my car for the second time. She told me she pulled into our small drive with no problems and switched the car ignition off, but had 'messed' on with the i-control for a few seconds trying to switch the radio off. She had also had to move the car's seating position when driving it. When I got in 30 minutes later to move the car out of the drive the car wouldn't start and began to display (crazily) numerous multiple faults (not all of which I am writing here):
- electronic steering lock on
- cruise control fault
- ABS fault
- windscreen wiper fault
- restraint fault
- side window fault
etc etc etc
Once I calmed down I tried to charge the battery but when this failed I went out and bought a new Bosch one thinking this would do the trick. I have just fitted it this morning but nothing has changed - in fact, there are now more faults showing......... Nightmare.
I have the recovery lorry coming to collect tomorrow as I have trawled the internet but can't get any pointers as to what it might be. I am really stumped and freaking over the possible huge bill I may be faced with.
Any help would be really appreciated.
 

·
Registered
Joined
·
8,981 Posts
It is a power related problem, so the faults are "ghosts" so to speak, and don't actually exist, but I can't remember a solution as yet. Either one module has a fault, or there is a minor electrical issue somewhere.

I think there is a module specific to the battery monitoring, a footwell module (FRM) or a Junction Box (JBE) module which could be the root cause.
 
1 - 3 of 3 Posts
Top