BMW Forums : BimmerForums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all,

I have a 52 plate E46 and its developed a poor starting fault. It turns over fine but fires like its been starved of fuel? Once running it idles fine with no loss of power and if you knock it off and restart it it starts fine, topically the fault reoccurs after being stood for around 20 mins! When this first started to happen the only fault code listed said something about air mass low ( sorry for the vaig fault code info but my trying to be help full brother used his code reader and didn't remember what it said when I asked him) anyway I fitted a new air flow metre and it seamed to fix the problem for about 4 times I started the car but the fault reoccurred? I've checked for faults again using the code reader and there are not listed fault codes or warming lights on dash? The only thing I've seen that is faulty on the car is the ambient temp sensor (it's reading 50c) and I have one on order (not that I expect this to fix the problem but I work on Daf and Renault trucks and the engine Ecu does use the outside temp a lot).


Wondering if my fuel pump relay is intermittently knocking off causing poor fuel supply at start up as I'd have thought anything else would give me a loss of performance but if I'm honest I don't do much on cars and stick to trucks so don't really know? Help would be massively appreciated as I'm sick of looking stupid when the thing don't start! Lol
 
1 - 1 of 1 Posts
Top