BMW Forums : BimmerForums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a BMW X 5 55reg great car. I’ve had it 6 years 100k in clock and runs like a dream but in the last few years every winter on the start up it smokes badly for about 10 secs then clears itself. Just had a hydro clean to clean the carbon but thats not worked. I changed the crank oil filter last year and that’s not cured it. Has anyone cured this? I’m desperate now. Please help.
 

·
Registered
Joined
·
1,342 Posts
O sorry I mean crankcase ventilation.
If crankcase vent is clogged, you will burn oil.

But most of time when burning oil, it engine problem ( piston rings).
 

·
Registered
Joined
·
641 Posts
Also check any leak-off pipes, they get hard, crack and let in air. Easy to replace.
 

·
Registered
Joined
·
420 Posts
Wont effect running as such, just make cold starts rough and smokey. May need excessive cranking in cold weather.
Can prevent DPF regens on the newer ones though so if you car has a DPF I wouldn't delay fixing them.
 

·
Registered
Joined
·
36 Posts
Wont effect running as such, just make cold starts rough and smokey. May need excessive cranking in cold weather.
Can prevent DPF regens on the newer ones though so if you car has a DPF I wouldn't delay fixing them.
mine is a 2005 55 plate 320cd, dont think it has a dpf ???
but i have 4 ngk glow plugs to go in at the same time the heated oxy sensor (lamda) gets done

thanks for the reply
 

·
Registered
Joined
·
2,415 Posts
I would fit a new control module at the same time but that's me.
My 320d has 1 or 2 failed (new parts ready to fit) and on start up on a very cold morning it's lumpy for around 5 to 10 seconds but starts just the same.
Never looked if i get any smoke lol will look this morning but it's not that cold.
 
1 - 13 of 13 Posts
Top