BMW Forums : BimmerForums banner

1 - 20 of 24 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello!!*

I have a facelift 535d e61 with 166000miles/270000km. And it came with a strange problem when i bought it... when I floor it the little turbo makes a quite loud screaming/whining noise... it goes away when the big turbo takes over around 3000rpm or so.

And the consumption is to high... on really urban driving. Nonstop drive gave this figures. 800km/500 miles, and the consumption is 35 mpg.
And at normal combined usage is around the consumption is around 24mpg. (And this is also pretty urban)

I we noticed that the*engine*use a lot more diesel than my remapped 530d 2007 preface.*

The 535d is supposed to be remapped, and the dpf is cutted up open and the dpf core is gone.
The last owner did this and said the car should have 350hp... but I don't think it goes any faster than my remapped 530d 2007 285hp 630nm. I actually think that my 530d have alot more torque at 1500-2500rpm.*

What I have done.

-New air mass meter.
-New*O2 sensor*in the*exhaust.
-New. both*exhaust*temp sensors.*
-New thermostat.
-New Glow plugs and that box that controls the glow plugs.
-New hoses pressure side on turbo. (Pressure tested 70 psi)
-New*air filter

Do any of you people have a clue of what is going on with my*engine?
 

·
Registered
Joined
·
772 Posts
The car couldn't keep up with the 'enjoyment' factor of the previous owner.

You need to read the codes, check both turbos. Probably need to replace the small turbo. Don't assume the map is good, it needs to be checked and if necessary corrected by a reputable mapper.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
Error codes:

Code: 00452A
Code: 00426E
Code: 0042AE
Code: 0042CE
Code: 0042DE
Code: 004166
Code: 004CF3
Code: 004B37
Code: 005DCF
 

·
Registered
Joined
·
3 Posts
Hello!!*

I have a facelift 535d e61 with 166000miles/270000km. And it came with a strange problem when i bought it... when I floor it the little turbo makes a quite loud screaming/whining noise... it goes away when the big turbo takes over around 3000rpm or so.

And the consumption is to high... on really urban driving. Nonstop drive gave this figures. 800km/500 miles, and the consumption is 35 mpg.
And at normal combined usage is around the consumption is around 24mpg. (And this is also pretty urban)

I we noticed that the*engine*use a lot more diesel than my remapped 530d 2007 preface.*

The 535d is supposed to be remapped, and the dpf is cutted up open and the dpf core is gone.
The last owner did this and said the car should have 350hp... but I don't think it goes any faster than my remapped 530d 2007 285hp 630nm. I actually think that my 530d have alot more torque at 1500-2500rpm.*

What I have done.

-New air mass meter.
-New*O2 sensor*in the*exhaust.
-New. both*exhaust*temp sensors.*
-New thermostat.
-New Glow plugs and that box that controls the glow plugs.
-New hoses pressure side on turbo. (Pressure tested 70 psi)
-New*air filter

Do any of you people have a clue of what is going on with my*engine?
Not sure wat could be wrong but your old car with 285 and 630, was that the ecotune decat? If so what you think of it as I'm looking at it

C


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
772 Posts
Code: 452A - DPF (you said it's gutted)
Code: 426E - IBS
Code: 42AE - DDE: BSD-Communication with oil-condition sensor
Code: 42CE - DDE: BSD-Communication with alternator
Code: 42DE - DDE: BSD-Communication with glow control unit
Code: 4166 - DPF
Code: 4CF3 - Exhaust back pressure sensor
Code: 4B37 - Oil condition sensor, communication
Code: 5DCF - DSC, under voltage or sensor?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
Code: 452A - DPF (you said it's gutted)
Code: 426E - IBS
Code: 42AE - DDE: BSD-Communication with oil-condition sensor
Code: 42CE - DDE: BSD-Communication with alternator
Code: 42DE - DDE: BSD-Communication with glow control unit
Code: 4166 - DPF
Code: 4CF3 - Exhaust back pressure sensor
Code: 4B37 - Oil condition sensor, communication
Code: 5DCF - DSC, under voltage or sensor?
So how do I sort our those problems?
 

·
Registered
Joined
·
2,815 Posts
The IBS error may be the place to start. Disconnect the IBS cable, clear the errors and see if they come back. Also suggest you get a reading from the voltage regulator.
 

·
Registered
Joined
·
107 Posts
Not sure wat could be wrong but your old car with 285 and 630, was that the ecotune decat? If so what you think of it as I'm looking at it

C


Sent from my iPhone using Tapatalk
I've got that. It's been great. Had it on my 08 530d for 3 years now. I use the eco map which is 260 HP I think.
No idea what the consumption to be honest I don't know why I don't run the more powerful one. I guess I never got round to trying both. I change the map next week as I forgot I had both.

Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
3 Posts
I've got that. It's been great. Had it on my 08 530d for 3 years now. I use the eco map which is 260 HP I think.
No idea what the consumption to be honest I don't know why I don't run the more powerful one. I guess I never got round to trying both. I change the map next week as I forgot I had both.

Sent from my SM-G930F using Tapatalk
Cool let me know how u get on with the maxi map, I am trying to hold out buying it !


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
107 Posts
Ok will do. The eco map is a noticeable improvement on the standard 231 HP. Very easy to drive. Smoother and quicker. But that's a quoted extra 29 over the standard. Not sure the 275 will be as noticeable but I'll find out.

Sent from my SM-G930F using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #12
Hmm, I have been thinking of all my fault codes and everything now some days and I have read the car for codes again... and here they are

Faultcode: Oil quality sensor
Faultset 1:
(appeared at: 271664.0km)
battery voltage:
14,83 V
vehicle speed:
0,00 km/h
Kilometers since last oil change:
2550,00 km
engine coolant temperature:
86,26 °C
Engine speed:
661,98 1/min
Motoroeltemperatur for CAN:
86,31 °C
Oelniveau - short-term average value:
0,00 mm
Oelniveau - long-term average:
40,14 mm
Oelniveau - orientation averaging:
0,00 mm
ambient pressure:
994,46 mbar
Faultcode: Oil quality sensor
Faultset 2:
(appeared at: 271808.0km)
battery voltage:
13,69 V
vehicle speed:
5,92 km/h
Kilometers since last oil change:
150,00 km
engine coolant temperature:
86,26 °C
Engine speed:
1130,88 1/min
Motoroeltemperatur for CAN:
86,31 °C
Oelniveau - short-term average value:
0,00 mm
Oelniveau - long-term average:
40,14 mm
Oelniveau - orientation averaging:
0,00 mm
ambient pressure:
964,92 mbar

Faultcode: Info-particle system
Faultset 1:
(appeared at: 271664.0km)
Ash in the particulate mass:
55,95 g
Differential pressure by particulate:
0,00 mbar
Injection quantity:
9,06 mg/Hub
engine coolant temperature:
86,26 °C
Boost pressure actual value:
925,54 mbar
Air mass per cylinder:
466,31 mg/Hub
Engine speed:
661,98 1/min
Rail Pressure Is:
299,32 bar
Russ mass in the particulate filter:
9,99 g
ambient pressure:
994,46 mbar

Faultcode: BSD message failure
Faultset 1:
(appeared at: 271664.0km)
battery voltage:
14,83 V
vehicle speed:
0,00 km/h
Kilometers since last oil change:
2550,00 km
engine coolant temperature:
86,26 °C
Engine speed:
661,98 1/min
Motoroeltemperatur for CAN:
86,31 °C
Oelniveau - short-term average value:
0,00 mm
Oelniveau - long-term average:
40,14 mm
Oelniveau - orientation averaging:
0,00 mm
ambient pressure:
994,46 mbar
Faultcode: BSD message failure
Faultset 2:
(appeared at: 271824.0km)
battery voltage:
14,17 V
vehicle speed:
0,00 km/h
Kilometers since last oil change:
160,00 km
engine coolant temperature:
82,25 °C
Engine speed:
1268,79 1/min
Motoroeltemperatur for CAN:
82,39 °C
Oelniveau - short-term average value:
0,00 mm
Oelniveau - long-term average:
40,14 mm
Oelniveau - orientation averaging:
0,00 mm
ambient pressure:
964,92 mbar

Faultcode: Communication with participants Intelligent Battery Sensor 0
Faultset 1:
(appeared at: 271664.0km)
Distance to Startfaehigkeitsgrenze:
37,50 -
battery voltage:
14,83 V
Battery voltage of IBS measured:
14,64 V
Battery power of IBS measured:
−62,65 A
battery temperature:
−0,00 °C
Injection quantity:
9,06 mg/Hub
vehicle speed:
0,00 km/h
Correction value shutdown:
−5,21 -
engine coolant temperature:
86,26 °C
Engine speed:
661,98 1/min
Faultcode: Communication with participants Intelligent Battery Sensor 0
Faultset 2:
(appeared at: 271824.0km)
Distance to Startfaehigkeitsgrenze:
39,58 -
battery voltage:
14,17 V
Battery voltage of IBS measured:
14,00 V
Battery power of IBS measured:
−3,78 A
battery temperature:
−0,00 °C
Injection quantity:
38,99 mg/Hub
vehicle speed:
21,71 km/h
Correction value shutdown:
−7,29 -
engine coolant temperature:
83,25 °C
Engine speed:
2344,51 1/min

Faultcode: BSD message failure
Faultset 1:
(appeared at: 271664.0km)
battery voltage:
14,34 V
Injection quantity:
9,45 mg/Hub
vehicle speed:
0,00 km/h
engine coolant temperature:
86,26 °C
Boost pressure actual value:
905,85 mbar
Air mass per cylinder:
441,11 mg/Hub
Engine speed:
661,98 1/min
Pedal value generator:
0,00 %
Rail Pressure Is:
307,20 bar
State of the glow indicator:
0,00 -
Faultcode: BSD message failure
Faultset 2:
(appeared at: 271824.0km)
battery voltage:
13,85 V
Injection quantity:
8,66 mg/Hub
vehicle speed:
23,69 km/h
engine coolant temperature:
85,26 °C
Boost pressure actual value:
866,46 mbar
Air mass per cylinder:
415,90 mg/Hub
Engine speed:
661,98 1/min
Pedal value generator:
0,00 %
Rail Pressure Is:
307,20 bar
State of the glow indicator:
0,00 -

Faultcode: BSD message failure
Faultset 1:
(appeared at: 271664.0km)
battery voltage:
14,34 V
Injection quantity:
9,06 mg/Hub
vehicle speed:
0,00 km/h
engine coolant temperature:
86,26 °C
Boost pressure actual value:
896,00 mbar
Air mass per cylinder:
390,70 mg/Hub
Engine speed:
661,98 1/min
Pedal value generator:
0,00 %
Rail Pressure Is:
307,20 bar
ambient pressure:
994,46 mbar
Faultcode: nullnull:[email protected]
Faultset 2:
(appeared at: 271824.0km)
battery voltage:
14,34 V
Injection quantity:
48,44 mg/Hub
vehicle speed:
33,56 km/h
engine coolant temperature:
83,25 °C
Boost pressure actual value:
2048,00 mbar
Air mass per cylinder:
1001,94 mg/Hub
Engine speed:
2234,18 1/min
Pedal value generator:
66,14 %
Rail Pressure Is:
1425,72 bar
ambient pressure:
964,92 mbar

Faultcode: [email protected]
Faultset 1:
(appeared at: 271664.0km)
Exhaust gas volume flow in the particulate filter:
760,69 m^3/h
Differential pressure by particulate:
0,00 mbar
Injection quantity:
45,69 mg/Hub
engine coolant temperature:
48,11 °C
Boost pressure actual value:
2284,31 mbar
Air mass per cylinder:
1272,91 mg/Hub
Engine speed:
2482,42 1/min
Pedal value generator:
43,31 %
Rail Pressure Is:
1291,82 bar
ambient pressure:
1004,31 mbar

Faultcode: null.nullOJ,[email protected]
Faultset 1:
(appeared at: 271696.0km)
Exhaust backpressure before particulate filter:
1043,69 mbar
Exhaust gas volume flow in the particulate filter:
660,38 m^3/h
Differential pressure by particulate:
0,00 mbar
Injection quantity:
48,44 mg/Hub
engine coolant temperature:
85,26 °C
Boost pressure actual value:
2510,77 mbar
Air mass per cylinder:
1298,12 mg/Hub
Engine speed:
1958,36 1/min
Rail Pressure Is:
1102,77 bar
ambient pressure:
1014,15 mbar
 

·
Registered
Joined
·
10 Posts
Discussion Starter #15
Is it possible that my DDE is broken in any way... can I check this in any easy way?

If not, do I need to bring the car to a Bmw dealership to make them find out what is going on with my DDE?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
Here are the codes after resetting the faults x10 times.
Info-particle system
Code: 00452A
Oil quality sensor
Code: 004B37
BSD message failure
Code: 0042AE
Communication with participants Intelligent Battery Sensor 0
Code: 00426E

BSD message failure
Code: 0042DE
BSD message failure
Code: 0042CE
Particle filter system
Code: 004166
Exhaust back pressure sensor
Code: 004CF3

Short circuit to positive or open circuit (AUC)
Code: 009C54
Power Management Battery voltage K-CAN
Code: 00E714
Code: 0063D0

I have also deconnected the IBS without any luck.
The alternator is charging 13.6-13.9v

I have open the DDE and checked it of moisture, but it was dry and didn't show any signs of corrosion or trauma.

So I really don't know what is going on... ��
 

·
Registered
Joined
·
772 Posts
Scan all control modules in inpa. E60 -> functional jobls -> error -> read EM and paste results like below. Also, need to know battery charge status over 5 days. Has car been sitting for months without being driven?


ERROR MEMORY
-----------------------------------
Date: 31.07.2016 12:25:59
Model: E60
Scope: all control module
JobStatus: OKAY
Quantity: 36
--------------------------------------------------------------
ADR Gen. name JobStatus Number of errors
Error code Kind of error

00 ZGM OKAY No Error stored
01 SIM/SGM OKAY No Error stored
02 SZL OKAY No Error stored
05 STVL/TEFA OKAY No Error stored
06 STVR/TEBF OKAY No Error stored
0E SFZ OKAY No Error stored
12 DME/DDE OKAY No Error stored
17 EKP OKAY No Error stored
18 EGS OKAY No Error stored
29 DSC OKAY No Error stored
36 TEL/MULF OKAY No Error stored
38 EHC OKAY No Error stored
3C CDC OKAY No Error stored
3F ASK OKAY No Error stored
40 CAS OKAY No Error stored
41 DWA OKAY No Error stored
43 POW OKAY No Error stored
44 SHD/MDS OKAY No Error stored
45 RLS OKAY No Error stored
47 ANTTU OKAY No Error stored
50 SINE OKAY No Error stored
60 KOMBI OKAY No Error stored
62 MOSTGW OKAY No Error stored
63 MMI/CCC OKAY No Error stored
64 PDC OKAY No Error stored
65 BZM/SZM OKAY No Error stored
67 ZBE OKAY No Error stored
6D FAS OKAY No Error stored
6E BFS OKAY No Error stored
70 LM OKAY No Error stored
72 KBM OKAY No Error stored
73 CID OKAY No Error stored
78 KLIMA OKAY No Error stored
A0 CCC OKAY No Error stored
A1 SBSL OKAY No Error stored
A2 SBSR OKAY No Error stored
=================================================================
 

·
Registered
Joined
·
10 Posts
Discussion Starter #18
Scan all control modules in inpa. E60 -> functional jobls -> error -> read EM and paste results like below. Also, need to know battery charge status over 5 days. Has car been sitting for months without being driven?


ERROR MEMORY
-----------------------------------
Date: 31.07.2016 12:25:59
Model: E60
Scope: all control module
JobStatus: OKAY
Quantity: 36
--------------------------------------------------------------
ADR Gen. name JobStatus Number of errors
Error code Kind of error

00 ZGM OKAY No Error stored
01 SIM/SGM OKAY No Error stored
02 SZL OKAY No Error stored
05 STVL/TEFA OKAY No Error stored
06 STVR/TEBF OKAY No Error stored
0E SFZ OKAY No Error stored
12 DME/DDE OKAY No Error stored
17 EKP OKAY No Error stored
18 EGS OKAY No Error stored
29 DSC OKAY No Error stored
36 TEL/MULF OKAY No Error stored
38 EHC OKAY No Error stored
3C CDC OKAY No Error stored
3F ASK OKAY No Error stored
40 CAS OKAY No Error stored
41 DWA OKAY No Error stored
43 POW OKAY No Error stored
44 SHD/MDS OKAY No Error stored
45 RLS OKAY No Error stored
47 ANTTU OKAY No Error stored
50 SINE OKAY No Error stored
60 KOMBI OKAY No Error stored
62 MOSTGW OKAY No Error stored
63 MMI/CCC OKAY No Error stored
64 PDC OKAY No Error stored
65 BZM/SZM OKAY No Error stored
67 ZBE OKAY No Error stored
6D FAS OKAY No Error stored
6E BFS OKAY No Error stored
70 LM OKAY No Error stored
72 KBM OKAY No Error stored
73 CID OKAY No Error stored
78 KLIMA OKAY No Error stored
A0 CCC OKAY No Error stored
A1 SBSL OKAY No Error stored
A2 SBSR OKAY No Error stored
=================================================================
I have icarly now... the app on my phone with Bluetooth adapter... this software is not enough I guess. . Where can I by this inpa software and cabel kit??
 

·
Registered
Joined
·
1 Posts
I have the same squealing noise under boost on my 335d e90

I have replaced the turbo and top oil pipe but still squeals like a pig..

Did anyone manage to fix this problem.

Any help would be great
Adam
 

·
Registered
Joined
·
10 Posts
Discussion Starter #20
I have the same squealing noise under boost on my 335d e90

I have replaced the turbo and top oil pipe but still squeals like a pig..

Did anyone manage to fix this problem.

Any help would be great
Adam
It was comming from the manifold, or more specific, a leak between the manifold and head due to a broken bolt that where stuck inside the head. I manage to get it out, and repair the faults. Engine singing like a bird again ??
 
1 - 20 of 24 Posts
Top