BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi there,

I have a 09 328i with x drive. Weird issue I’m having: I took to out of storage last week and it drove fine for a couple days. Then I went o breakfast and tried to start it, no crank to start. The key then got stuck in the ignition module, I still get no start. I tried to jump start thinking it might be the battery but that wasn’t it. Getting p1020 and p164c codes. It doesn’t crank but makes one single click. Famous BMW exclamation point as well. Weird thing that also happened was after a couple minutes, the windshield wipers turned on out of nowhere, I wasn’t even in the car.
Has anyone had a similar issue or is able to help?
 

·
Registered
Joined
·
2,672 Posts
Could be the starter-motor.
I take it the car is automatic so no chance of rocking it in gear then.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Could be the starter-motor.
I take it the car is automatic so no chance of rocking it in gear then.
Yeah it’s an automatic unfortunately. I was thinking starter too. I just don’t understand why all the light and everything, then the windshield wipers.... BMWs work weirdly.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
You might want to get the battery drop tested as well just to be sure.
Did a load test on battery after charging from car for 30 minutes, still no start, bounced to 8 volts after loading. Trying a new battery.
 
1 - 7 of 7 Posts
Top