BMW Forums : BimmerForums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all. Had my battery on charge all over night and checked it this morning and its showing 12.5 volts of power yet cone to starr my 320d 2014 and all I get is a click and nothing...on occasion the glow plug signs cones up. So ibe got max battery power but something stopping it firing, I drive it daily 40k miles and parked it up Friday, went to it Saturday and nothing, immediately thought I'd left a light on so charge full overnight.....and again this morning nothing ...thanks Steve
 

·
Registered
Joined
·
2,116 Posts
12.5 volts after all night charge is not quite enough.
Can you get somebody to try and start the car while you check the voltage at the battery.
My guess is the battery has failed.
Saw one on Saturday new battery fitted then car left to sit for 6 months = new battery is dead and won't charge but showed 12.5v when on the Snap-on charger.
 

·
Registered
Joined
·
4,580 Posts
Friend with a spare 12V battery?
Hook up in parallel with jump leads and may answer IF it's battery related.
Or one of those newer fangled emergency start setups, similar idea..
And agree with Alan G, 12.5V not really good, I know they label 12V but on charge can show 14.5 - 14.8ish, as in with engine running, an ammeter might show what's happening when try to start...
 

·
Registered
Joined
·
2,116 Posts
12.6v or a bit above is fully charged.
After being charged then left to stand for an hour or 3 that is what it should show.
 
1 - 5 of 5 Posts
Top