BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Evening All!

I have bitten the bullet and traded my Audi TT 1.8T 225bhp for a 2004 645i Coupe.

I have always fancied a V8 and this has not disappointed....That was until i got it home and gave it a cheeky rev to see a cloud of blue smoke come out of the exhausts.

My heart just sank because it didn't do this when i went to pick it up. I have also noticed now that it has a puddle of water/coolant below the water pump and a little on the floor...JOY

So i hear the blue smoke could be due to the PCV or Stem Seal. Symptoms at the moment are fine on Idle and when moving. Only when i gave the throttle a blip from idle after a drive. I have ordered replacement PCV due to BMW wanting £70, so i have to wait to check if its them. I have seen lots of threads created about them and a handy manual to replace them through Timms guide it should be a doddle. Previous owner has done a muffle delete, and says its only ever had a bit of smoke since hes done that....

Onto the water pump, i have been assured by the owner that he topped the coolant up around 1.5 litres in September last year and not touched it since. No warning lights are present but i definitely have something going on there. Again i have seen a very useful guide on replacing that due to its position, hardest bit is getting the belt on and off i believe?

Anyway. Its a fantastic car and i thoroughly enjoyed the drive home. I just wish the day didnt end on a slightly sour note

Gavin in Chester
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Car is booked into SJR BMW Specialist in Chester, as they are local to me and have good reviews. Even though the car has had a health inspection at BMW Blackpool after it had the battery connector recall in September last year, they didn't pull anything up.

The PCV parts have arrived today so i will install them today :D
 

·
Super Platinum BFuk Member
Joined
·
942 Posts
Hi Mate, Did you buy /partex privately? because it does sound like you have been stitched up? but hope you get it sorted?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Hi Mate, Did you buy /partex privately? because it does sound like you have been stitched up? but hope you get it sorted?
Hi Steve,

Yes I have swapped my trusty reliable TT Privately.

The coolant (or what I thought it to be) is actually pure water. Its dripping from just behind the drain pipe for the cabin/pollen filters. So a small win that it isn't coolant atleast!

Took her for a drive yesterday, no blue smoke when I gave her a rev.

I have replaced the PCV Diaphrams but the original ones were in good condition.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Still none the wiser as to what the dripping is. Hopefully tomorrow at SJR Chester they will have a diagnoses.

In the mean time I have been investigating why the front speakers aren't working. Previous owner said the amp had flooded and he had it repaired. Rear speakers and floor subs are working. Front speakers are working only giving out bass.

Could I be right in thinking it could still be the amp or the head unit?

About the amp too. I have found it is still dripping from behind the tail lights. Has anyone got a fix besides bonding it all up like the previous owner did?
 

Attachments

1 - 7 of 7 Posts
Top