BMW Forums : BimmerForums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
120 Posts
Discussion Starter #1
Some of you may remember a while ago I was trying to find a solution to carry my bike on my 435 convertible. After looking at many different options, the only realistic solution was a towbar - I already had a bike rack which I used with my wife’s car. Found very little online about anyone that had fitted a towbar to a convertible, but here are the results, which I’m very pleased with. It’s detachable when not in use.

T

175EF405-7543-4FB7-B251-ABEFCACBEBBB.jpg
160322DA-CE61-473F-B10B-452E34365286.jpg
91540BFE-5F48-4965-B574-90B32A243925.jpg
E5F6225C-9B90-4BC5-BB25-0AE6EF3809FC.jpg
 

·
Registered
Joined
·
120 Posts
Ok, so let’s have some details then ��
I want one on mine, which make, how much and who did it would be useful, as well as any issues...
Cheers
J
 

·
Registered
Joined
·
3 Posts
Ok, so let’s have some details then ��
I want one on mine, which make, how much and who did it would be useful, as well as any issues...
Cheers
J
Some of you may remember a while ago I was trying to find a solution to carry my bike on my 435 convertible. After looking at many different options, the only realistic solution was a towbar - I already had a bike rack which I used with my wife’s car. Found very little online about anyone that had fitted a towbar to a convertible, but here are the results, which I’m very pleased with. It’s detachable when not in use.

T

View attachment 242377
View attachment 242385
View attachment 242393
View attachment 242401
Hi Tony
can you please confirm which lights should work on the above cycle carrier. I have just purchased on and connected to my brother's tow bar to check it out and the headlight and brake lights did not appear to be working. I'm wondering if they should work (I would have thought so ) so are mine faulty, or is it just a case of them not working on my brother's car but would potentially work on mine when I get a tow bar fitted with a "7-pin Vehicle Specific Wiring Kit" ?
Thanks
Theresa
 

·
Registered
Joined
·
1 Posts
Your car has likely LED lights, if the lights on your lightboard are standard bulbs it's likely/maybe that the mix is messing with the BMW systems. If you have a vehicle specific wiring loom fitted it might help...or not.
Micky
 
1 - 4 of 4 Posts
Top