BMW Forums : BimmerForums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi,
I'm having a problem with the gearbox (I think) in my 320d. When accelerating at motorway speeds a loud knocking noise starts at about 90mph and stops then once I ease off. I first thought it was a suspension noise but then the conssistency of the speed it starts at it must be in the box?

Anyone else had an issue like this? Car drives perfect otherwise. Has 120k on the clock, not sure if the gearbox has been serviced (I've had it since 75k). Noticed it probably not as smooth as when I bought it lately, but only slightly.

Any ideas? Costly repair? Would a service do anything at this stage. Any help appreciated ?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Update:

Think the problem is somewhere else in the drivetrain now. The consistency of the speed it starts at is strange though? Noise can vary from mild scraping to clunking and had an occasional loud bang...

Anyone with any ideas? Going to try get it up on a ramp tomorrow. Hopefully it will be something obvious at least.
 

·
Registered
Joined
·
37 Posts
Either way personally I would get the box serviced if you intend to keep the car. I know BMW UK state it's sealed for life but frankly that's boll*cks. ZF who actually make the box say to service at 80k if I remember right.
Mine threw an error and limited the speed around 90k. which disappeared on restarting the car. Had it serviced and now at 120k also nice and smooth.
You'll find the zf service kits on eBay or Amazon much cheaper than from a dealer or just go a good specialist. The one I use is listed on ZF's website as a certified service engineer.
 
1 - 3 of 3 Posts
Top