BMW Forums : BimmerForums banner
1 - 20 of 20 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
Hi

I have a 640d, and getting a drivetrain error. The error does not come on regularly, but usually within the first couple of minutes of driving after a cold start. The drivetrain error clears itself within 30 seconds and the car drives normally with full power.

I used bimmerlink to scan for codes, the codes that come up are:

25CE00 - Boost pressure sensor, range: upper physical limit exceeded

244C00 - Boos pressure control, control deviation: boost pressure too low / positive control deviaton

Advice and suggestions welcome

Thanks
 

·
Registered
Joined
·
4,403 Posts
i get those codes along with a few others,getting my pressure converters changed,had boost sensor changed which did cure limp mode for a while,but mine drives perfect,except when hitting very high speed and pedal all the way down,140 mph then it pops up
 

·
Registered
Joined
·
15 Posts
Discussion Starter · #3 ·
i get those codes along with a few others,getting my pressure converters changed,had boost sensor changed which did cure limp mode for a while,but mine drives perfect,except when hitting very high speed and pedal all the way down,140 mph then it pops up
Thanks for the reply

How do you know its the pressure converters? is there any values we can check on bimmerlink to confirm this?

Its very strange or a coincidence the error occurred after I have had mine remapped
 

·
Registered
Joined
·
4,403 Posts
Thanks for the reply

How do you know its the pressure converters? is there any values we can check on bimmerlink to confirm this?

Its very strange or a coincidence the error occurred after I have had mine remapped
diagnostics(ista) id get your map checked.who mapped it ?
 

·
Registered
Joined
·
879 Posts
Interesting you have both got the same issue with the same car and tuner, might be worth having a word with Jason to see if it is a map issue.
cheers
Jim
 

·
Registered
Joined
·
4,403 Posts
Interesting you have both got the same issue with the same car and tuner, might be worth having a word with Jason to see if it is a map issue.
cheers
Jim
yup,especially with me getting other work done for the codes etc,i will text him now and tell him to look at posts,,
 

·
Registered
Joined
·
4,403 Posts
private messaged him on here,no reply,will text him tomorrow,didnt want to bother him on weekend,although i have before
i scanned car yesterday,after around 3 weeks of driving ,previously cleared the codes,got 2 codes back,charge air pressure sensor range,upper physical limit exceeded 245400,,,and particulate filter system minimum differential pressure undershot 25cE00..not had any limp mode and drove hard a coup[le of times to about 120 mph,always use paddles and change jsut as peak torque is in band
 

·
Registered
Joined
·
4,403 Posts
this is why im getting converters replaced,,read this a while ago and same info my indy gave me,ive had 3 diagnostic sessions with him,good post this..https://f30.bimmerpost.com/forums/showthread.php?t=1695619&page=2,couple of times indy has said,could be the mapping,i had already said i didnt think it could be that as jason is good ,he sort of agreed with a twisted face if you know what i mean,sort of as if i knew more than him,,we shall see,
 

·
Registered
Joined
·
879 Posts
Let us know if the pressure converters make a difference. I have suspicion mine might be getting weak and thinking of putting new ones on.
cheers
Jim
 

·
Registered
Joined
·
4,403 Posts
Let us know if the pressure converters make a difference. I have suspicion mine might be getting weak and thinking of putting new ones on.
cheers
Jim
bmw indy doing the work phoned me yesterday,supposed to dropm car off to me last night,but one of the new converters had a nipple missing,typical,car will be ready today though
 

·
Registered
Joined
·
4,403 Posts
Let us know if the pressure converters make a difference. I have suspicion mine might be getting weak and thinking of putting new ones on.
cheers
Jim
car dropped off last night,not had a chance to fully test it,but seems a little more responsive altho it never really felt flat,only prob was drivetrain warning at very high speed,and some extra smoke at high revs ,ie pulling hard from nearly standstill in 1st/2nd/3rd etc etc,and say doing 120 mph and flooring it upto silly speeds,very rarely do that kind of thing but but wen i do, i want no limp mode, put foot down briefly a few times and never seen any smoke out rear window,will keep posted,,
 

·
Registered
Joined
·
4,403 Posts
well thats a twat,drivetrain warning and limp mode,,right at where it happened last tim ,and same ish speed,nearly 140 mph,got a nice bit of cleat road so had to test it,and the jag behind xfr 5,0,never gained any ground until i hit limp mode around 50 metres behind when i put foot down and him,got to have a play now and again,not worth having a powerful car if not
 

·
Registered
Joined
·
879 Posts
That is really annoying and I hate it when faults like that take some chasing. Keep us updated.
cheers
jim
 

·
Registered
Joined
·
4,403 Posts
That is really annoying and I hate it when faults like that take some chasing. Keep us updated.
cheers
jim
yeh,jason has been in contact with me,i did show him this topic,he has advised me that all 3 converters should be changed,,will post back
 

·
Registered
Joined
·
4,403 Posts
was at garage yesterday,did diagnostics/back pressure tests etc,,,guy ius leaning towards dpf has a problem,ie hole inside etc,,,we went out and logged it,im gonna send the logged file to jason as the guy has e mailed it to me,,no cost for yesterday,and was £215 for the 2 converters replaced..he also reset the parameters for the converters,,while we were out,the car threw no codes,,so will try and test car over weekend,not easy as u think,as getting foot down with clear road to over 130 mph is hard with todays traffic,wouldnt do it with traffic on inside lane etc,anyone could pull out on me
 

·
Registered
Joined
·
133 Posts
My 2014 F11 535d has also been remapped by BW Chiptune (to about 370bhp) and when scanning the car for an unrelated issue got fault codes - 244B00 boost too high, negative deviation - as well as the 25CE00 code.
Please keep us updated.

Sent from my SM-G960F using Tapatalk
 

·
Registered
Joined
·
879 Posts
The plot thickens a bit more. That’s three cars tuned by the same person with the same issues. Hopefully you all get sorted or Jason is able to identify a remedy as can’t be a coincidenc.
cheers
Jim
 
1 - 20 of 20 Posts
Top