BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hi All, Just a fun one. I have not put her onto the laptop and checked codes yet but looking for places to start with.
Briefly last Friday replaced the Air bellow rubbers from the MAF to Throttle body as i had a weird idle surge and possible leak in a boot.
I cleaned the MAF sensor and with A/C on and car running reset the Adaptations and all seemed to be very happy.

On a trip from London to York and back over the weekend on the motorway i noted engine light flickered and went off then the ASC and ABS lights came on.
when this happened i lost cruise control and the speedo and mpg gauges stopped working as well.
after several minutes the lights went off and the speedo slowly raised back to the correct speed but still no cruise.

Any clues as these should be completely unrelated to the cleaning of the MAF, i can understand that cruise would be effected if the ASC and ABS lights were on due to possible failures as a safety precaution.

Anyway trip back the same, every so often the ASC and ABS lights come on and then go off the speedo would stop working and then come back and no cruise control functions ?

i have a pic of when she completely stalled in traffic but started back up OK, ill check with the laptop and INPA tonight to see if any codes but any suggestions ? or any one have ASC / ABS lighting issues ? or just a Electrical Gremlin in the system
coincidently at the same time i swapped the boots.

Thanks for any suggestions. IMG_6114.jpg
 

·
Registered
Joined
·
2,864 Posts
What vehicle is this? Sounds possibly like moisture in the electrics somewhere a fault some of the tourers are prone to.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Ta, just been reading the forums and a lot point to NSR Wheel Sensor supposedly reads Vehicle Speed, ASC and ABS !! so loose plugs there or slowly dying or needs a clean.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #6
Error codes retrieved

OK i have managed to pull the codes from the ECU.

130 Can Signal ASC timeout
214 Vehicle Speed Signal VSS

There are no actual sensor codes or advice to say left or right, So with these and no obvious Module or Pump errors either and no number 8 MAF errors like i had before cleaning it, vehicle speed to instrument and ASC should/could be a faulty NSR ABS Sensor !
I believe this one does the cluster speed, ABS and ASC. so ill try cleaning it first and report back.

thoughts !
 

Attachments

1 - 7 of 7 Posts
Top