BMW Forums : BimmerForums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi Everyone,

Just wondered if someone could offer some advice.
I have a 2010 320d Cab.

Near Christmas time I started experiencing electrical problems. I was getting the low battery voltage warning on the dash, angel eyes not turning on when unlocking the car and rear window demister not working, also the start/stop hasn't worked for a couple of months.

I had a look in the boot and the battery tray was full of water. The drainage holes were completely blocked. It went into a local indie who unblocked the drains and replaced some cables under the battery that were corroded. They told me they'd tested the battery and also the IBS sensor and they were both fine. They put my power issues down to the corroded cabling.

Fast forward a month and I'm still having the electrical problems. I have a CTEK charger/re conditioner and when I charge the batter everything (bar the stop/start) works again for a couple of weeks.

I took it back to the indie for another look earlier in the week. They tested the battery and the IBS sensor again and declared them fine, charged the battery and sent me on my way, saying if it happens again they'll keep it for a few days, as possible there's a battery drain when the car's asleep. I think I do enough mileage to keep it charged, a 70 mile round trip each day to work.

So if the battery and IBS sensor are fine, does anyone have any idea what may be up, or what might be causing a drain? There are no aftermarket things fitted

Alex
 

·
Registered
Joined
·
1 Posts
Is your problem solved? I"m thinking it might be that your battery needs replacing. Mine is still the original one from 2010, yours probably too.
 
1 - 2 of 2 Posts
Top