BMW Forums : BimmerForums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all,
Recently, I've noticed an issue with the front left, particularly whilst driving around a right-hand bend and using some braking. I can only describe what I feel like a twitch/skid, with the Traction Light flashing as it happens. It's very concerning, particularly whilst at high speeds. At low speeds, the steering wheel isn't central, and pulls to the left. If I'm braking in a straight line, the car almost feels like it's floating toward the left and I have to be wary of how I'm handling the steering wheel when doing so.

Took it to a garage last week and they told me "it all looks fine. Wheel alignment was fine, tyres are fine". However, the issue still persists.

I took a photo of the underside of the car, and something that immediately caught my eye, was the housing around the CV joint (?) looks as though it's worn away. Could this be the issue? If so, how serious of an issue is it?

Thanks.


274370
 

·
Registered
Joined
·
3,316 Posts
No cv joint on the front of your car.
I had something like your problem but on my x5 and it turned out to be the bottom ball joint opposite end to your red circle.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
No cv joint on the front of your car.
I had something like your problem but on my x5 and it turned out to be the bottom ball joint opposite end to your red circle.
Thanks. Really appreciate the reply.

Was it a costly repair?
 
1 - 6 of 6 Posts
Top