BMW Forums : BimmerForums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter · #1 ·
Hi all

Apologies if there is a thread already open on this issue.
A couple of Months ago I purchased e92 335d m sport

169,000 Miles (engine recon 27k ago wotn receipts etc)
Re mapped to 360 bhp at map tech
Dpf delete, egr valve delete all done at map tech Doncaster when re map was done
Car has been perfect till engine light came on the other day

Using obd scanner these faults came up along wit the one that was already there about the dpf

4166dde particulate filter system
4cf3 dde exhaust back pressure signal
3f25 dde

Now if I boot it bellows Of black smoke come out tbe back and it won’t go above 80mph, when I clear the faults black smoke still there but feels quicker

when normal driving no black smoke at all

many help/ advice will Be greatly appreciated
Thanks
 

·
Registered
Joined
·
3,654 Posts
I get a cloud of black smoke but only when i use the kick down for the first time after many miles but it clears in a couple of seconds.
People will say unburnt fuel but not sure myself.
I used to open the pump on my truck after mot test and it went a lot faster but i got the black smoke.
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #3 ·
Hi Alan.
Thanks for your reply.

my car was ok but now when I put my foot down the black smoke is continuing until I let my foot off, engine light comes on and I get the fault codes.

I clear tbe codes and boot it again and the codes come back.

mice got an inpa witn software taht cake won’t that came with the cat but I don’t know if that would give me anymore detail and to be honest I’ve never used one before
 

·
Registered
Joined
·
3,822 Posts
could be anything from boost sensor/egt sensor/maf sensor etc,need codes read preferably ista+
 

·
Registered
Joined
·
21 Posts
Discussion Starter · #5 ·
Hi Rasa- thanks for your reply.
Inpa/ista Dongle came with car- not used one before but I’m sure I’ll work it out, I’ve loaded software on laptop ready , I’ll try and find my way round it and come back- really appreciate the help and advice . Thanks all
 

·
Registered
Joined
·
3,654 Posts
Just click inpa and see how you get on.
Not sure on it myself i use a snap-on scanner but did try inpa a long time ago but my memory is not good lol.
 

·
Registered
Joined
·
3,822 Posts
run it for codes,,,if it was a boost hose im sure it would rear its head well before 80 mph,,loads of things it could be from dpf/egr/vacuum related faults etc etc
 
1 - 9 of 9 Posts
Top