BMW Forums : BimmerForums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hi all.
Late last year I had an issue where randomly whilst driving a lot of electrical issues would start to occur.
First the boot open warning would randomly come on and off, followed by the dials on the instrument cluster going down to 0 and coming back to life again in a split second.
This would always be accompanied by a clicking sound from the glovebox (I presume a relay?).

The issue went after stopping and starting the car, and after it happened the second time I realised the car needed to have the earth lead recall doing and presumed this was a symptom.

That got done at the beginning of the year, and I haven't had the issue since until today.

However today there was an electrical smell that came from the glovebox, followed by the ticking sound along with not only the intermittent boot open warning but also the abs light and red hand brake light came on.
I was close to home so I thought I would be able to get back safely and do some fault finding, however after a few minutes the clicking stopped and all of the warning lights also disappeared.

Does anyone have any clues as to what this may be? I'm guessing a dodgy relay but any other help would be appreciated.


Many thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Was the heater blower on full? Is the car part of that recall?
Hi mate.
It was on low, I think I had the a/c on earlier in the trip.
The car had both the blower and ground lead recall done in January.


Cheers
 

·
Registered
Joined
·
194 Posts
I'd start by checking earth connections at the battery to body and motor to body, and do a drop test on the battery to make sure it's in good condition. Then check any relays you can get to ...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks! I'll do a check through that tomorrow.
I did a fault code check as well:
2020-05-23 18:27:13

3'/E90/2007/Auto / D60M57A0

------------------------------------------------------------

MOTOR (!) [Engine]

4212 Glow plug cylinder 1, control

4222 Glow plug cylinder 2, control

4232 Glow plug cylinder 3, control

4242 Glow plug cylinder 4, control

4252 Glow plug cylinder 5, control

4262 Glow plug cylinder 6, control

4993 message (STAT_KOMBI, 0x1B4)

------------------------------------------------------------

ACC [Adaptive cruise control]

No response from ecu

------------------------------------------------------------

AHM [Trailer module]

No response from ecu

------------------------------------------------------------

CAS [Car access system]

No faults

------------------------------------------------------------

CCC [MASK / RAD / CCC / CIC (radio/entertainment)]

No faults

------------------------------------------------------------

CTM [Cabrio top module]

No response from ecu

------------------------------------------------------------

DSC (!) [Dynamic stability control]

D35A No description available

5DBA No description available

5DE1 No description available

------------------------------------------------------------

DWA [Anti theft alarm]

No faults

------------------------------------------------------------

EGS (!) [Gearbox]

CF35 No description available

------------------------------------------------------------

EKP [Electric fuel pump]

No faults

------------------------------------------------------------

EPS [Electric steering]

No response from ecu

------------------------------------------------------------

FLA [High beam light assistant]

No response from ecu

------------------------------------------------------------

FRM [Footwell module (lights)]

No faults

------------------------------------------------------------

FZD [Functions centre roof]

No response from ecu

------------------------------------------------------------

IHKA (!) [Air conditioning]

E71A No description available

E71C No description available

------------------------------------------------------------

JBBF (!) [Junction box]

A6CF No description available

A6D1 No description available

C904 No description available

------------------------------------------------------------

KOMBI (!) [Instrument cluster]

A3BD No description available

9319 No description available

931A No description available

A550 No description available

A3AE No description available

------------------------------------------------------------

MRS [Multiple restraint system (airbags)]

No faults

------------------------------------------------------------

NAV [Navigation]

No response from ecu

------------------------------------------------------------

PDC [Park distance control]

No faults

------------------------------------------------------------

RDC [Tire pressure module]

No response from ecu

------------------------------------------------------------

RLS [Rain-Light sensor]

No faults

------------------------------------------------------------

SBSL [Satellite B-pillar left (airbags)]

No response from ecu

------------------------------------------------------------

SBSL [Satellite B-pillar left (2) (airbags)]

No response from ecu

------------------------------------------------------------

SBSR [Satellite B-pillar right (airbags)]

No response from ecu

------------------------------------------------------------

SBSR [Satellite B-pillar right (2) (airbags)]

No response from ecu

------------------------------------------------------------

SFZ [Satellite vehicle center (airbags)]

No response from ecu

------------------------------------------------------------

SINE (!) [Anti theft siren]

9D12 No description available

------------------------------------------------------------

STVL [Satellite door front left (airbags)]

No response from ecu

------------------------------------------------------------

STVR [Satellite door front right (airbags)]

No response from ecu

------------------------------------------------------------

SZL [Control center steering column]

No response from ecu

------------------------------------------------------------

----- bimmer-tool 2.170-expert -----

When I reset the codes the glow plug faults stayed (looks like the module is gone), but the kombi and junction box codes clear.

Cheers
 
1 - 5 of 5 Posts
Top