BMW Forums : BimmerForums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hello all

I have a E60 525d SE 2005 UK registered with professional navigation system (ie with map) package fitted which up until yesterday has worked flawlessly.

It now seems to have lost the ability to identify its current position whilst the car is in motion. When the car is stationary it is spot on but as soon as the car in motion it becomes confused and shows my location randomly up to two miles away. Apart from this system seems to be operating normally ie map is still displayed etc just that my location is way out. When I stop within 15s it has updated my position correctly.

Have tried rebooting iDrive (both eject buttons and volume pushed simultaneously) and have also tried another BMW DVD in drive in case DVD has become defective in some way.

Any thoughts apart from an expensive visit to my local BMW main dealer at £135 per hour?

Cheers

Alan
 

·
Uber Platinum BFuk Member
Joined
·
1,428 Posts
Hi Farrina,

Funny thing you mentioning that. My I-drive froze and the wheel became free hand / spin (no tension). The first time that has ever happened (I have a 2055 E60 too, and pro nav). It seemed to recover ok when I pressed the menu button.

I don't know what to suggest, maybe I got a firmware or software update on my last visit without me knowing it.....

Anyone else have any ideas? Red
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
No snow on the costa Mersey (Welsh hills take it all on our behalf)

It has been suggested on another BMW forum :embarrassed that the problem may be with the antenna.

I am told that the Sharkfin can allow the ingress of water which may result in the antenna degrading.

This would make sense in so far as the position is accurately shown whilst stationary and only becomes faulty once the car is moving, suggesting that it is only capturing the basic three satellite feed when stationary and then is unable to lock on once moving.

Does anyone know if there is an easy way of checking this - ie is the Sharkfin easily removable or is this a job for a dealer?

Cheers

Alan
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
It's very weird but following a trip up North (well 80 mile around trip) my Sat Nav has started working normally again.
I have no absolutely no idea why - fingers crossed it stays "fixed"

Thanks to all for your suggestions and helpful advice.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top