BMW Forums : BimmerForums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
16 Posts
Discussion Starter #1
Hi,

I have 30e9 nitrgoen-oxide catalytic converter,ageing message. i have this message for a while, but yesterday i felt that i lost power and on idle started little bit shaking. So plugged in obd reader to check, and i had mixture control messages 29e0, 29e1, 2a2c, 2a2b.
So i drive back home,deleted readings and left car till today. This morning started driving, i have power back, car is not shaking on idle, so was driving aroud 20min all ok, however plugged in obd reader i have only 30e9 nitrogen-oxide catalytic converter,ageing message, but i though i will check datastream, when i saw figures, i think something is not right.
So i made pictures to share with you guys? what you think?
Signal, oxygen sensor 2 behind catalytic converter -285.55 and additional mixture adaptation -345.23 when tapping acceleration pedal around 3k rpm it goes to 0.

IMAG0238.jpg 3.jpg 5.jpg 4.jpg
 

·
Registered
Joined
·
16 Posts
Discussion Starter #2
Hi,

I have 30e9 nitrgoen-oxide catalytic converter,ageing message. i have this message for a while, but yesterday i felt that i lost power and on idle started little bit shaking. So plugged in obd reader to check, and i had mixture control messages 29e0, 29e1, 2a2c, 2a2b.
So i drive back home,deleted readings and left car till today. This morning started driving, i have power back, car is not shaking on idle, so was driving aroud 20min all ok, however plugged in obd reader i have only 30e9 nitrogen-oxide catalytic converter,ageing message, but i though i will check datastream, when i saw figures, i think something is not right.
So i made pictures to share with you guys? what you think?
Signal, oxygen sensor 2 behind catalytic converter -285.55 and additional mixture adaptation -345.23 when tapping acceleration pedal around 3k rpm it goes to 0.

View attachment 223442 View attachment 223450 View attachment 223458 View attachment 223466
more findings:
when car cold working fine, but after driving 20-30mins on idle car is shaking and reving, also i have another code today 2d29 Differential-pressure sensor, intake manifold:plausibility

any ideas?
 

·
Registered
Joined
·
2,807 Posts
This could be a bunch of things from a vac leak to a flaky MAF. The sensor may be failing but look at the simple stuff first.
 

·
Registered
Joined
·
16 Posts
Discussion Starter #4
This could be a bunch of things from a vac leak to a flaky MAF. The sensor may be failing but look at the simple stuff first.
Thanks snowblind.
Anyway i believe this is crankcase valve fault( ccv/pcv) i dont know even how it calls properly) but after research, done small test, it`s very hard to open oil cap while idling and it makes whistle sound, also white smoke comes from exhaust.
What you guys think?
 

·
Registered
Joined
·
16 Posts
Discussion Starter #5
Quick update!
It was CCV problem! membrane has been damaged that is why i had control mixture codes and all those symptoms.
I bought membrane and aluminium cap from vanos-bmw.com replaced and sealed with liquid gasket seal and car now back to normal, so avoided by replacing whole rocket gasket which would be very expensive.

still have catalytic converter ageing code, which i think it leads to faulty o2 sensor. question is how to check which one could be faulty?
 

·
Registered
Joined
·
437 Posts
if your fuel trim numbers are back to normal around 0, it could be a faulty after cat sensor, this sensor monitors the cats performance.
the pre cat sensors control fuel trims
 

·
Registered
Joined
·
16 Posts
Discussion Starter #7
if your fuel trim numbers are back to normal around 0, it could be a faulty after cat sensor, this sensor monitors the cats performance.
the pre cat sensors control fuel trims
It`s better when used to, but still doesn`t look right...
Previously i had sensor2 behind catalytic converter -285 now 60v
aditional mixture adaptation was 345, now is 106.

So it could be pre cat sensor swhich controls fuel trims?
 
1 - 7 of 7 Posts
Top