BMW Forums : BimmerForums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi everyone new to the form and looking for some help

I have 2008 530d e60 and since buying the car 3 weeks ago I have noticed a low down boost issue and a fumes smell inside the cabin in my ownership I have done the following
I went to change the engine breather nothing in the housing no vortex or Loo roll type empty?
intake manifold off new seals and vac lines changed
New Bosch Maf
Cleaned map sensor
if I’m cruising along and in a low Rev if I accelerate slightly it absolutely piles thick black smoke with little or no boost down low when it gets over 2200k it’s pulls great and smoke is reduced still there but reduced? I have been told the egr is mapped out still there I have pulled the vacuum line on and off no change the dpf has been removed aswell I could understand a smell from the rear but not in the cabin it’s horrible, if anybody could shed any information would be greatly appreciated thanks in advance.

edit: also have read about the exhaust manifold no signs of smoke or soot there either
 

·
Registered
Joined
·
3,574 Posts
Hi everyone new to the form and looking for some help

I have 2008 530d e60 and since buying the car 3 weeks ago I have noticed a low down boost issue and a fumes smell inside the cabin in my ownership I have done the following
I went to change the engine breather nothing in the housing no vortex or Loo roll type empty?
intake manifold off new seals and vac lines changed
New Bosch Maf
Cleaned map sensor
if I’m cruising along and in a low Rev if I accelerate slightly it absolutely piles thick black smoke with little or no boost down low when it gets over 2200k it’s pulls great and smoke is reduced still there but reduced? I have been told the egr is mapped out still there I have pulled the vacuum line on and off no change the dpf has been removed aswell I could understand a smell from the rear but not in the cabin it’s horrible, if anybody could shed any information would be greatly appreciated thanks in advance.

edit: also have read about the exhaust manifold no signs of smoke or soot there either
sounds like a boost hose is split,get them checked,,or manifold is cracked
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thanks for the info lads nothing obvious so far I’ve noticed the swirl flaps were removed and the actuator left on its own and the vac pipe plugged from the boost sensor? I also thought they revised the manifold in 07?
 
1 - 4 of 4 Posts
Top