BMW Forums : BimmerForums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
155 Posts
Discussion Starter #1
Any one got any idea's?

The car drives really, really well at times and others its a bit flat, almost like I'm in the wrong gear - but moving into sport and manually dropping a gear there is still a delay in pick up.

Sometimes the car doesn't want to start on first turn doesn't matter if cold or hot can be after a long journey or in the morning, anytime there doesn't seem to be a link with temperature.

And stalling, again as above doesn't seem to be related I can be driving and if I stop at light, slow down whilst pulling into a spot the engine drops its revs just a little too far?

These issues aren't there all day every day just random, but they are definitely becoming slightly more noticeable.
 

·
Registered
Joined
·
155 Posts
Discussion Starter #3
Had a few other people mention it could be that!

Guess I need to get it scanned IIRC only dealer check can bring the BMW codes up, is this true?

Any idea what they normally want for this?

Popping over to dealers tomorrow to collect some caliper seals so want to see if they are offering a fair price (really annoys me that we have to pay to get codes read?)
 

·
Registered
Joined
·
7 Posts
Hi Guys

My 320i has got the same probs had it put on diagnostic. It came up with cam sensor. Going into the garage monday to have new sensor fitted, going to change cankshaft one also. Was told to use only BMW ones.

Will let you know how it got on
 
1 - 4 of 4 Posts
Top