BMW Forums : BimmerForums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi folks,

Having some trouble with rough idling and stalling.

The car appears to idle fine until warmed up. When coming to a stop, the car will stall.

Timing chain and tensioner were done by a garage 4 months ago (3 month warranty).

I replaced the solenoid o rings this morning and topped up around 500ml oil. Previously, the car had a slight 'burp' at idle and the code P0139 - O2 Sensor Circuit Slow Response.

After topping up oil and changing o rings, I get the codes: (Torque Pro/£15 obd2 reader)

P0011 "A" Camshaft Position - Timing over advanced
P0015 "B" Camshaft Position - Timing over-retarded

I checked solenoid connections and then switched positions of the top and bottom solenoids. I kept them connected via their original connectors and refreshed the codes:

P0012 "A" Camshaft Position - Timing Over-Retarded
P0015 "B" Camshaft Position - Timing over-retarded



Where do you think I should start? Replacing the o rings was easy and I don't know what could have went wrong during this process to then throw up these codes and have it cutting out.

I have CCV kit on order, plus O2 and crankshaft sensors arriving tomorrow.

Thanks folks.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #2
Few views but no replies.

Anyway, here's an update for anyone interested...

Timing is A-OK (including chain/tensioner). Oil pressure good. Borrowed some solenoids and issue persisted.

I'm almost certain it is the Valvetronic Unit which is causing issues here. Have disconnected and symptoms disappear. I'm studying Electrical Engineering so this should be fun to resolve.

I'll continue with my planned works which include:

OE Camshaft sensors
OE Crankshaft sensor
CCV
Full fluid change and fuel filter
Proper clean of solenoids
Clean of all electrical connectors
O2 sensors

Cheers
 
1 - 2 of 2 Posts
Top