BMW Forums : BimmerForums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,015 Posts
Discussion Starter · #1 ·
Can you guys post up what spec hifi you have in your cars please.
I have the standard fronts with kenwood 6x9's under the original rear speaker pods running a kenwood headunit and it sounds pants.

I need some advice please. I would like some more bass, thats where the problem lays really. It seems the car is so well made the bass dosnt travel through it very well.

HELP :)
 

·
Registered
Joined
·
471 Posts
I got standard bmw speakers front and rear, vibe 10 inch active sub 1300watts and a kenwood kdc-w3041a it sounds good for the setup i got.

what kenwood head unit is yours.
if you want more bass install a sub id say 12inch and above it will look better and give you more bass depending on the sub and amp
 

·
Platinum BFuk Member
Joined
·
820 Posts
Got an old Sony head unit,think its CDX F500 50 wattx4 job, that powers the Vibe Black Air 5 Components in the front,got a Blaupunkt GTA 460 800 watt Amp powering a Blaupunkt GTW1200 200 watt Sub and some Vibe SEK69 6x9s, you can feel the bass moving your hair and the rear view mirror vibrates:jaw-dropping

Edit: Just read through your post again, no matter what car youve got youre not gonna have decent bass without a sub and amp
 

·
Platinum BFuk Member
Joined
·
261 Posts
You wont put much better than infinity 6x9`s , everywhere ive ever been i sugest removing them and upgrading and everyone says the same , had the same set for almost 2 years now .
I run them from a DLS 5 channel amp and usually dls components up front , but i am going a bit more hi-tec this time i think . Maybe rainbow or Cerwin Vega HED 5 or something along those lines. I will keep the DLS amp as it has stood the test of time.
I run 2 x 12" Rockford Fosgate T1 subs from 2 kenwood 1000w mono amps .
It is run by an impulse 5 farad power cap .
In 2005 , a friend of mine who owns the local Audio shop , his managers father is a rep for kenwood and managed to pick up probably the last of the 150 Kenwood 25 anniversary DVD players with TV and chip pan , washing machine , the lot .
Ok the last two i was kidding but it done everything . And it had a price tag to go with it . No discount as it could be sold a thousand times over , £1500 .
Yes £1500 .
Add that to the system i had just completed and total cost Approx £4500.
Now the head unit has gone but the rest it in process of being installed just now .

Needless to say i never declared it to the insurance. Something else worth considering .

As for bAss issues . I run it in a coupe , with a single sub running of the 5 channel (temp measure, changing cars) . I feel the bass in the car now. No idea what it will be like one the 2 subs are running of their own amps. Phenomenal if i take a guess .:hihi:hihi:hihi
 

·
Registered
Joined
·
710 Posts
Currently....NONE! Thats right, I ripped it out...

Soon....Ahhhh now you'll have to hold your horses and wait and see...
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top