BMW Forums : BimmerForums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
312 Posts
Discussion Starter · #1 ·
Gday to all and happy new year :D

On a recent trip to the 12 Apostles (will load photos soon - geological feature on the south cost of Oz), I somehow lost the ability to select the sport mode using the Manual, Economy, Sport switch.

The leds no longer light up and the switch no longer seems to do anything.

Any thoughts or advice on this?
 

·
Registered
Joined
·
312 Posts
Discussion Starter · #2 ·
Auto sport selector switch

ok - not surprised no responses, couldn't find any info anywhere on the net. Couple of guys on the US forum responded, but only to suggest getting another switch.

Bought one off UK ebay for 10 quid, so will let all know how goes when it arrives....
 

·
Registered
Joined
·
1,423 Posts
Did see your post but can't find any diagrams of what the switch actually operates. There was another thread a while ago when the switch burnt out then was replaced and burnt out again I think, which made me think it operated a solenoid or something that was sticking.
Hope the new switch does the trick.
 

·
Registered
Joined
·
20,393 Posts
ok - not surprised no responses, couldn't find any info anywhere on the net. Couple of guys on the US forum responded, but only to suggest getting another switch.

Bought one off UK ebay for 10 quid, so will let all know how goes when it arrives....
I was away yesterday and it was late when you originally posted, I was probably counting sheep :hihi

Have you tried dismantling the switch carefully and checking it out?
 
1 - 4 of 4 Posts
Top