BMW Forums : BimmerForums banner
1 - 6 of 6 Posts

·
Banned
Joined
·
110 Posts
Discussion Starter · #1 · (Edited)
hi:frown:confused

got my car back from the garage to replace lower arms , then drove the car for around 2hrs then noticed engine noisey-

I opened the bonnet , found the engine mounts bushes broke both sides- is it possible the garage did something or caused this as they were trying to remove the lower arms-what do u think?

bit strange- but im putting down to the knock I had hit curb at about 30mph b4 lower arms fitted

anyway I bought new engine mount bushes and have put them on to the body but the engine wont line up,
do the bushes go on the engine mount first or is it ok to put the bushes on the body

at present I have the car on the ramps is this correct way?
also when I jack up the engine from the sump using (2x4) the engine wont lift straight - do i really need a engine hoist?
help
ne 1 got a guide?;)
 

·
Bimmerforums Central
Joined
·
8,030 Posts
Right
The engine mounts shouldnt have just 'failed' like that , but you cant prove the garage did it either

Have you had a 4 wheel alignment ? if not I would get one.

Attached is a guide on how to replace your motor mounts correctly...
 

·
Banned
Joined
·
110 Posts
Discussion Starter · #3 ·
e36 engine mounts

Mmmm

ok well when the garage put the new lower arms they did the tracking then, will i need to do it again.
 

·
Bimmerforums Central
Joined
·
8,030 Posts
Mmmm

ok well when the garage put the new lower arms they did the tracking then, will i need to do it again.
Have you read the guide?

A 4 wheel alignment is not just tracking. It checks all geometry of the suspension at each corner and sets it perfectly to what BMW specifies in their tech manuals.

Are you 100% sure you have located the mounts correctly? as they have locating lugs

And yes, you lower the engine on to the mounts when they are in correct position.

You are using a jack and 2x4 under the engine to lift it right?
 

·
Legendary BFuk Member
Joined
·
12,959 Posts
A little persuasion with a pry bar also helps:thumbsup

Mine were an absolute biatch to get off when I was removing the engine on the touring, just resorted to a little BRUTE force :hihi
 

·
Banned
Joined
·
110 Posts
Discussion Starter · #6 · (Edited)
hey folks

wot a nightmare ,, still have not replaced engine mounts , the mounts are on the body but the engine will not filt in place - I think due to gearbox and driveshaft connected too much weight.

i even hired a engine crane but i think there was too much weight as everytime I tried too lift the engine the crane would just lean foward it , wouldnt lift.

Iv tried everything I think il leave to the prOs.

I think because I was driving at the time of the bushes failing , the engine has moved from its original position so therfore putting the bushes on is ok , but monouvering the engine onto the bushes is not happening.

car wil be at the mechanic soon.
 
1 - 6 of 6 Posts
Top