BMW Forums : BimmerForums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
196 Posts
Discussion Starter #1
OK so I drove home a couple of weeks back with no problem, parked the car on the drive and now it won't start.

It turns over quite happily
I've read the codes and got 3 glow plugs not working and rail-pressure on start fault (which is what I'm most worried about). If I clear the codes and try again, I get the same ones back so I'm sure these are all related to my problem.
When I turn the ignition on I can hear a low pitched hum which stops it I pull the fuse for the fuel pump (no 54 I think) and returns with the fuse replaced. I'm guessing the hum I can hear is the fuel pump so I'm assuming that's OK.

So, is there a single point of failure somewhere that could be causing the above? I've had a good check of all the fuses in the glove-box - are there anymore anywhere? I'm guessing there's a fuel filter somewhere which may be blocked - where is it?

Any other ideas before I given and call the RAC?

Thanks all.

Paul
(its a touring if that makes any difference.)
 

·
Registered
Joined
·
21 Posts
Fuel filter is under the car on the passenger side, remove the plastic protection and you'll see it, diesel pump is in the same place.

What exactly are the error code for rail-pressure ?
 

·
Registered
Joined
·
196 Posts
Discussion Starter #4
Thanks all - typical it would be passenger side wouldn't it - with the car tucked hard up against the hedge to give plenty of room on the drivers side...
This is what I got reading the codes - anything else ringing alarm bells? (not too bothered about glow plugs at the moment - if I can get it running I can sort those later)

E R R O R M E M O R Y ---------------------------------------
Date: 28.09.2014 18:17:37 ECU: D50M47A JobStatus: OKAY Variant: D50M47A -------------------------------------------------------------
RESULT: 4 error in error memory ! -------------------------------------------------------------

4B90 4B90 rail pressure monitoring at engine-start
Error counter: 255 Logistic counter: 40

1. Umweltsatz Mileage 219450 km
average engine rotational speed 0.00 rpm
coolant temperature 20.01 deg C
maximum common-rail-pressure of last 10ms 0.00 bar
injection volume setpoint without volume offset 32.69 mg/cyc
intaken air mass per cylinder 0.00 mg/Hub
charge pressure value 994.46 hPa
linearised APP1 0.00 %
Battery Voltage 11893.62 mV
Vehicle speed 0.00 km/h
Atmospheric-pressure 994.46 hPa

2. Umweltsatz Mileage 219450 km
average engine rotational speed 193.08 rpm
coolant temperature 20.01 deg C
maximum common-rail-pressure of last 10ms 110.28 bar
injection volume setpoint without volume offset 42.14 mg/cyc
intaken air mass per cylinder 397.00 mg/Hub
charge pressure value 994.46 hPa
linearised APP1 0.00 %
Battery Voltage 10427.28 mV
Vehicle speed 0.00 km/h
Atmospheric-pressure 994.46 hPa

Signal or value above threshold
Test conditions fulfilled
Error present now, but not yet stored (debouncing phase)
Error would not cause a warning lamp to light up
Fehler in Entprellphase
Fehler in Entprellphase
Fehler in Entprellphase
Error code: 4B 90 41 06 00 00 FF 28 55 B9 00 46 00 53 00 65 00 49 00 65 55 B9 07 46 0E 6B 3F 65 00 40 00 65 -------------------------------------------------------------

4212 4212 Glow plug zylinder 1
Error counter: 1 Logistic counter: 40
Mileage 219450 km
average engine rotational speed 0.00 rpm
coolant temperature 20.01 deg C
maximum common-rail-pressure of last 10ms 0.00 bar
injection volume setpoint without volume offset 32.29 mg/cyc
intaken air mass per cylinder 0.00 mg/Hub
charge pressure value 994.46 hPa
linearised APP1 0.00 %
Battery Voltage 11567.77 mV
Vehicle speed 0.00 km/h
status glow scale 0.00 -
No signal or value
Test conditions fulfilled
Error present now, but not yet stored (debouncing phase)
Error would not cause a warning lamp to light up
Fehler in Entprellphase
Fehler in Entprellphase
Fehler in Entprellphase
Error code: 42 12 44 02 00 00 01 28 55 B9 00 46 00 52 00 65 00 47 00 00 -------------------------------------------------------------

4222 4222 Glow plug zylinder 2
Error counter: 1 Logistic counter: 40
Mileage 219450 km
average engine rotational speed 0.00 rpm
coolant temperature 20.01 deg C
maximum common-rail-pressure of last 10ms 0.00 bar
injection volume setpoint without volume offset 32.29 mg/cyc
intaken air mass per cylinder 0.00 mg/Hub
charge pressure value 994.46 hPa
linearised APP1 0.00 %
Battery Voltage 11567.77 mV
Vehicle speed 0.00 km/h
status glow scale 0.00 -
No signal or value
Test conditions fulfilled
Error present now, but not yet stored (debouncing phase)
Error would not cause a warning lamp to light up
Fehler in Entprellphase
Fehler in Entprellphase
Fehler in Entprellphase
Error code: 42 22 44 02 00 00 01 28 55 B9 00 46 00 52 00 65 00 47 00 00 -------------------------------------------------------------

4232 4232 Glow plug zylinder 3
Error counter: 1 Logistic counter: 40
Mileage 219450 km
average engine rotational speed 0.00 rpm
coolant temperature 20.01 deg C
maximum common-rail-pressure of last 10ms 0.00 bar
injection volume setpoint without volume offset 32.29 mg/cyc
intaken air mass per cylinder 0.00 mg/Hub
charge pressure value 994.46 hPa
linearised APP1 0.00 %
Battery Voltage 11567.77 mV
Vehicle speed 0.00 km/h
status glow scale 0.00 -
No signal or value
Test conditions fulfilled
Error present now, but not yet stored (debouncing phase)
Error would not cause a warning lamp to light up
Fehler in Entprellphase
Fehler in Entprellphase
Fehler in Entprellphase
Error code: 42 32 44 02 00 00 01 28 55 B9 00 46 00 52 00 65 00 47 00 00 =============================================================
 

·
Registered
Joined
·
196 Posts
Discussion Starter #6
Thanks Mr End...

Been a busy week so not had chance to look at it yet (Also, like I said up there ^^^ it'll be pain as the car has the passenger side jammed against a hedge to I'd have to tow it away a bit before I could get under that side...)
I was wondering though - I saw somewhere else that the fuel pump relay is the same as another one (horn?) where are they - is it worth me swapping them as a test? (Yes, I am putting off going underneath it...)

If I can still hear humming with the ignition on, is that a sign that the pump is OK and its the filter that's blocked?

Cheers
Paul
 

·
Super Moderator
Joined
·
3,632 Posts
Another possibility is a leaky injector. Too much leak off will cause the rail pressure not reaching high enough for start. In the second logged code the rail pressure was 110 bar when cranking (RPM 193). The rail pressure on start should be near 300 bar. In this case you can usually start the engine with the aid of some brake cleaner sprayed in the intake (remove boost hose on the EGR valve for this). If this proves to be true you need to measure the leak off on the injectors.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #8
Well, that was an odd one.
Mr RAC came out and squirted some magic juice into the air inlet and it started on the 2nd attempt. After that it started first go every time.
I'm going to leave it now and try again tomorrow morning when its cold and see what happens.
Thanks for the help and ideas folks.
 

·
Registered
Joined
·
196 Posts
Discussion Starter #9
Well, its finally sorted.
The prize goes to Clavurion - 2 leaky injectors were stopping the pressure getting high enough (and 4 faulty glow plugs one of which had sheared off years ago by the look of it weren't helping).
Thanks all :thumbsup
 
1 - 9 of 9 Posts
Top