BMW Forums : BimmerForums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have recently purchased a 1990 E30 318is, which has been unused for around 18 months and has been parked outside. It started fine with a battery booster and I was able to drive it to its MOT with no problem. Having got it back from the garage it has developed a problem where it will start and idle (a little erratically when cold but then settles) but as soon as I press the throttle, it won't take the power and usually cuts out at that point. Any ideas on where to start my checks would be really helpful. Thanks.
 

·
Registered
Joined
·
298 Posts
Get the codes read, always your first port of call. Sounds to me as though it may be the MAF or crank/cam position sensor(s).
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Thanks for the speedy response....had suspected it might be air-flow related. When you say reading codes, do you mean by plugging into a diagnostics kit? Cheers
 

·
Registered
Joined
·
20,393 Posts
I have recently purchased a 1990 E30 318is, which has been unused for around 18 months and has been parked outside. It started fine with a battery booster and I was able to drive it to its MOT with no problem. Having got it back from the garage it has developed a problem where it will start and idle (a little erratically when cold but then settles) but as soon as I press the throttle, it won't take the power and usually cuts out at that point. Any ideas on where to start my checks would be really helpful. Thanks.
Weak spark, lack of fuel(pressure) or a knackered air flow meter will cause this.

Check the distributor cap, fuel pressure, check for presense of a big bright blue spark at the leads.
 
1 - 4 of 4 Posts
Top