BMW Forums : BimmerForums banner
1 - 20 of 56 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter · #1 ·
Over the past month or two my coolant warning light has been coming for a few moments, sometimes for as long as 5 minutes then goes off. Doesn’t happen on every drive, sometimes it’ll go a few weeks without happening.

I’ve checked the coolant level and it’s nice and high both when cold and just after it’s been running.

What are the chances it’s something like a faulty sensor rather than something more costly?
 

·
Registered
Joined
·
1,058 Posts
Mine did this ...

The fault was the radiator/aircon condenser ... The radiator 'bows' top and bottom, leaks when hot, and I assume, closes when cooled ... so 'apparently' only losing none or small amounts of coolant. In fact I replaced the rad, condenser, expansion tank and cap and a few other bits & pieces, clips etc .. I think a sensor senses a pressure drop as well as the coolant level, as that explained the light (on mine) but no to little coolant drop, but could be wrong.

As you can see, it ain't a pretty sight, but this was a 15 year old car when it happened .. ;)

Grass Wood Plant Motor vehicle Mesh
 

·
Registered
Joined
·
61 Posts
Discussion Starter · #3 ·
Cheers for that - did your sensor light randomly come on and go off though? Surely if it was detecting a ‘leak’ whilst hot the light would stay on until the engine cooled down and then would go off?
 

·
Registered
Joined
·
1,058 Posts
Cheers for that - did your sensor light randomly come on and go off though? Surely if it was detecting a ‘leak’ whilst hot the light would stay on until the engine cooled down and then would go off?
Yes, but I used to run Landrovers offroad which were always overheating, so whenever the light came on I slowed, let it cool until it went off and almost always didn't come back on that journey .. and it didn't do it every journey, even when being pushed hard!! Definitely seemed to me to be electrical at first until I took off the front fan pack and looked at the rad!! I'd already had trouble with the expansion tank too ... changed caps etc.
 

·
Forum Chatbot
Joined
·
3,708 Posts
F*** sake…this just gets worse.
LOL join the club. I'm after a Jap car now. Spent a lot of time with issues on my coolant system before.

My coolant just emptied itself last night but I think it's because the cap Leaked it judging by the spray marks. I believe the product I used to try to mend the head gasket is helping it leak because you can see these tiny coloured debris from the product both coming out of the cap and the little bleed valve surprisingly.
 

·
Registered
Joined
·
4,169 Posts
have you checked waterpump,,they can go,,i had this but wasnt losing to much coolant,,new waterpump solved it,,e46 330d,,had to take viscous fan off then wobble water pump shaft etc to see if any play in it,sure enough there was quite a bit
 

·
Registered
Joined
·
238 Posts
Have you bled the system just to make sure it isn't trapped air? Mine did this originally and a bleed sorted it. Bleeding the system can be a bit of a fiasco and it has to be done right.

Maybe worth looking at, especially if it can save you a £ or two.
 
1 - 20 of 56 Posts
Top