BMW Forums : BimmerForums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Dear Members,
I have an E90 LCI year 2009 318i VIN A502676 N43 Engine Direct injection.

The car start normal at cold, let it idle till it become hot that is reaching operating temperature around 60 deg C.

After reaching approximately 114 Deg Celsius, the radiator fan does not come on and the engine dies by itself. The radiator fan does not turn on even the engine coolant temperature is at 114 Deg Celsius and the radiator outlet sensor is 108 deg Celsius.

Fault code are:-
1. 30EA Nox
2. 2A2B Mixture control
3. 29E0 Mixture control
4. 29CC Combustion misfires several cylinders
5. 2EF7 Map thermostat activation. ( I changed MAP thermostat and no more fault come on)

Fault 2A2B, 29E0 and 29CC only comes when the engine dies but Fault 30EA is PERMANENT. Will a nox sensor prevent a car from starting ONLY when the engine is HOT.????
Now if you try to start the car when hot, the engine crank but will not start. At this moment while the engine is cranking I checked if the low pressure fuel pump in the tank is pumping fuel to the high pressure rail and pump YES. I checked if fuel is reaching top of the injectors YES ( very high pressure).
I checked if the the spark plug fires while cranking yes. But the injectors will not open while cranking that is the DME is not actuating the injectors to open.WHY????? I checked and confirm that the crankshaft and camshaft sensors are good.
This only happen when the engine is HOT above 80 Deg Celsius. If you allow the car to cool down for about 20 minutes and the temperature is 60 deg celsius the car will start fine again.

I changed the Map thermostat and problem still here. I also checked if I received 5 volt at the thermostat 2 pins YES. The wiring is good.

I swap the the VANOS Solenoid, problem still same. I also perform a full engine flush problem still here.

This is a very interesting point while the engine is cold and running:-

With my scan tool I can actuate the Radiator fan, electric water pump and radiator shutter ALL WORKS. But when the engine is hot that is above 95 deg celsius I cannot actuate the Radiator fan, electric water pump and radiator shutter. My scan tool says test failure and they will not respond. But if you allow the car to cool down again everything will works fine.

Hope I explain me well.

Please help me to solve this problem.

Thanks
 

·
Registered
Joined
·
166 Posts
If your scan tool is able to see live data, Have a look at the RPM value when trying to start it from warm. If you get no value, the Crank sensor is shot and needs replacing. If they fail, the ECU doesn't know when to provide fuel or spark, so just sits dormant until it's able to determine the engine timing.

Had crank sensor issues on 2 previous cars, replaced and was fine after. Not sure how common it is on the BM though.
 

·
Registered
Joined
·
2 Posts
Dear Members,
I have an E90 LCI year 2009 318i VIN A502676 N43 Engine Direct injection.

The car start normal at cold, let it idle till it become hot that is reaching operating temperature around 60 deg C.

After reaching approximately 114 Deg Celsius, the radiator fan does not come on and the engine dies by itself. The radiator fan does not turn on even the engine coolant temperature is at 114 Deg Celsius and the radiator outlet sensor is 108 deg Celsius.

Fault code are:-
1. 30EA Nox
2. 2A2B Mixture control
3. 29E0 Mixture control
4. 29CC Combustion misfires several cylinders
5. 2EF7 Map thermostat activation. ( I changed MAP thermostat and no more fault come on)

Fault 2A2B, 29E0 and 29CC only comes when the engine dies but Fault 30EA is PERMANENT. Will a nox sensor prevent a car from starting ONLY when the engine is HOT.????
Now if you try to start the car when hot, the engine crank but will not start. At this moment while the engine is cranking I checked if the low pressure fuel pump in the tank is pumping fuel to the high pressure rail and pump YES. I checked if fuel is reaching top of the injectors YES ( very high pressure).
I checked if the the spark plug fires while cranking yes. But the injectors will not open while cranking that is the DME is not actuating the injectors to open.WHY????? I checked and confirm that the crankshaft and camshaft sensors are good.
This only happen when the engine is HOT above 80 Deg Celsius. If you allow the car to cool down for about 20 minutes and the temperature is 60 deg celsius the car will start fine again.

I changed the Map thermostat and problem still here. I also checked if I received 5 volt at the thermostat 2 pins YES. The wiring is good.

I swap the the VANOS Solenoid, problem still same. I also perform a full engine flush problem still here.

This is a very interesting point while the engine is cold and running:-

With my scan tool I can actuate the Radiator fan, electric water pump and radiator shutter ALL WORKS. But when the engine is hot that is above 95 deg celsius I cannot actuate the Radiator fan, electric water pump and radiator shutter. My scan tool says test failure and they will not respond. But if you allow the car to cool down again everything will works fine.

Hope I explain me well.

Please help me to solve this problem.

Thanks
Hi, did you get issue solved?
i have exact replica of the issue you have described.
so far i have changed fuel pump, temp sensor, sprak plugs and coils. No luck. As soon as engine gets into 90+ C it is not possible torestart unless i wait for 15-20 min for cooldown
 

·
Registered
Joined
·
2 Posts
I m facing the same issue with same engine. If it reaches 85 degrees or more, it doesn't start anymore. I have to wait until it cools down to 85 or below. Also, If i remove the engine coolant temperature sensor, the car starts right up. Did you fix the issue by replacing the injectors, Ilkin? You are my last hope man.
 
1 - 10 of 10 Posts
Top