BMW Forums : BimmerForums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi guys, i have a 318i e90 and recently it has started to cut out with complete power loss. So far, i have not found a pattern to it yet, but have noticed that even though it cuts out completely, I will put it in neutral to roll up to a suitable spot, and it will not completely die, but instead idles perfectly fine, then i will try and drive off again, and will within a few seconds, have complete power loss.

I have noticed that it is not directly related to the digital temperature readout, but it seems to run for at least 15mins if i leave the car for a long period of temperature, thus suggesting, it may be somewhat related to temperature.

I have recently had to do a pcv valve replacement which was not working properly and chucking out a lot of smoke for a while, and i have checked for fault codes, and saw that there is a vanos intake fault code up (2a83), so i'm going to inspect that today, but i don't think this would cause this complete loss of power, like as if it had all electricity cut out...

Does any one have any ideas? i think one of the key bits of info, is that even though it has 100% power loss, it still idles fine. Any help is much appreciated! Thanks
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
So i checked the vanos solenoid connectors and cleaned them up, inspected the solenoids and they look really good condition and then swapped them over, but the 2a83 code stayed, so i guess that must be something else related to it. I will investigate this further when i have time.

However i dont think the car cutting out is related to this, so i want to focus on this. What i have noticed is that after the car cuts out, i have 2 fault codes turn up...
Fault code 1: 2CA2, oxygen sensor heating before catalytic converter
Fault code 1: 2CA3, oxygen sensor heating 2 before catalytic converter


Also, I found that the Lambda value, cyl. 2 and 3 remained exactly at 15.73

Does this mean that the 02 sensor is broken, and should i just replace one of them or both?
 
1 - 3 of 3 Posts
Top