BMW Forums : BimmerForums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hi guys, I have a bmw x5 2009 e70 3.0 sd. The problem with the car is that when i put my foot down the engine cuts out, i took it to a bmw specialists to hook it up to a computer and check for faults, it came back saying that the 4th, 5th and 6th injectors are having activation problem. The car now fully cuts out when started. I would like to know if anyone has encountered such problem and know anything i could do to stop it? I am looking into buying 3 injectors which would cost me over a £1000 which i would like to prevent if possible.

Thanks
 

·
Super Moderator
Joined
·
3,498 Posts
The injectors have continuous positive voltage supply from DDE (engine control unit) and they are activated by connecting the ground (with FETs). There is a separate voltage supply for 1-3 and 4-6 injectors. As the fault is on injectors 4, 5 and 6 the problem must be on this positive side. Remove the wiring from injectors and DDE and measure that none of the individual wiring pairs are not shorted. If wiring is OK you can measure the positive voltage and compare it on bank 1-3 and 4-6. CLICK
 

·
Registered
Joined
·
2 Posts
Hi all,
I have the same issue but now it is getting worse.
My 2009 X5 3.0sd (x35D) was shutting off the engine when I tried accelerate hard. It happened once a month so I didn't do anything with it. Then it started do it more often up to the point that it was shutting off the engine on idle. I took it to bmw shop and they showed me a list of codes:
4929 Injector, cylinder 4, activation
436D Reducing agent metering, long-term adaptation
4B99 Injectors, bank 2, activation
459B Smooth running controller, cylinder 5
46E6 Subsequent injection volume 1, plausibility
46E7 Subsequent injection volume 2, plausibility
4BB9 Injector, cylinder 4, activation
4BBF Injector, cylinder 6, activation
483D Throttle actuator
4593 Smooth running controller, cylinder 2
4596 Smooth running controller, cylinder 3
4592 Smooth running controller, cylinder 4
459C Smooth running controller, cylinder 1
4595 Smooth running controller, cylinder 6
4CF0 Misfire detection in several cylinders
4CE2 Misfire detection, cylinder 5

They deleted all codes and after few starts and engine shuts off computer returned 2 codes:
4B99 Injectors, bank 2, activation
483D Throttle actuator

Now car won't start at all. I replaced injector 4 and 6 but it didn't help. Still showing the 2 codes above. Any suggestion what to check?
 

·
Registered
Joined
·
2 Posts
Quick update. I replaced injector 5 as well and everything is back to normal. No more codes. Car runs fine. Hope it helps somebody in the future.
 

·
Registered
Joined
·
4 Posts
Hi had a problem with my 2007 e70 3.0sd m sport cutting out leave it a minute and it would fire up and you could do 1 mile or 100 miles before it would cut out again very random .I had it plugged in to a snap on code reader and came up with codes all relating to injectors .My mate who is a mechanic stripped it and tested the injectors and came up with a low reading on number 5 which seems to be a problem on a lot of forums relating to the number 5 injector .He said that he had suspicions of it being number 5 because the diesel feed pipe had corrosion over it as if it was getting wet .On inspecting a bit further he said that there is a join in the covers above 5 and it seems to be dripping water on to number 5 and thinks this was the cause .Changed number 5 because he said the chances of them all going is very unlikely and fingers crossed 200 miles and no problems hope this might help someone in the future
 

·
Super Moderator
Joined
·
3,498 Posts
The seam on the pollen filter housing is on top of Nr.5 cylinder. On petrol engines it's more typical that this causes problems on that injector but same could happen on diesels too.
 

·
Registered
Joined
·
1 Posts
bmw x5 e70 3.0d 2007

Hi
Im having problems with my 2007 x5 at the moment
I had a diagnostics done but no codes came up, they did find water ingress on injector no5
The plastic cover under the bonnet was cracked just above injector no5 but that has now been sealed
I was told to change the fuel filter which ive done and ive done the egr valve cleaner on the air intake, if i drive up the road it stalls, if i let it tick over for a while its fine but as soon as i put it into gear d or r it stalls, would it be the no5 injector thats my problem or something else
 

·
Registered
Joined
·
1 Posts
Hi, I have a X5 E70 2007 3.0d and today the engine cut out. It start again after a while. Once it start I plugged in and show “short positive on injector 4 and 6. No faults on the dash. Sometimes it start and drive 2 miles and cut out. Sometimes it’s driving 100 and cut out. Any idea?
 

·
Super Moderator
Joined
·
3,498 Posts
Hi, I have a X5 E70 2007 3.0d and today the engine cut out. It start again after a while. Once it start I plugged in and show “short positive on injector 4 and 6. No faults on the dash. Sometimes it start and drive 2 miles and cut out. Sometimes it’s driving 100 and cut out. Any idea?
Measure injectors from both pins against injector body with multimeter. The resistance should be over 180 kohm. Measure all injectors on the same bank (4-6). If a multimeter resistance is still within specs the faulty ones can be ruled out with insulation resistance tester (250-500 V). (The problem with these piezo injectors is that the element shorts internally.)
 
1 - 10 of 10 Posts
Top