BMW Forums : BimmerForums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
249 Posts
Discussion Starter #1
My 2006 E63 630i (N52) has a slight flat spot around 1300 RPM and a very slight idle pulse of about 20-30 RPM. Having replaced many of the suspect hardware (sparks, coils, vanos solenoids, check return valves, PCV, Eccentric Shaft Sensor, and tested for vacuum leaks, it was suggested that I update my DME, EKP and EGS.

I've checked my vehicle data in INPA and found that it has never been updated since leaving the factory in 2006 (strange as the SA had previously commented that it was 'up-to-date' on a previous visit for an oil change). My Userinfo is listed below (MULF is 2010 only because I replaced it)

I've only recently popped my coding cherry so I'm a bit apprehensive about taking the next step (flashing!!). I've done some research and checked my module versions and this is my current understanding:

1) DME
Current DME ZUSB was not found in WinKFP so I checked the MSV70.HIS file where I found 7563568 replaced by 7568956. This could not be found in WinKFP either but I realised this was in-turn replaced by 7581258. 7581258 was found in WinKFP and linked to MSV70 as I was expecting. I proceeded to choose Update ZUSB and selected MSV70. The dialog box confirmed an update from 7563568 to 7581258.​
2) EKP
Current ZUSB of 7180427 was found in WinKFP linked to EKM260. Update ZUSB confirmed an update from 7180427 to 7276382.​
3) EGS
Current ZUSB of 7564226 was found in WinKFP linked to GKE211. Update ZUSB confirmed no update available (both values 7564226).​
So, my questions are as follows:

  1. Do my above findings look ok?
  2. Why no update for the EGS? Is it possible that 7564226 from 2006 was the last update for this or am I possibly missing datens?
  3. Once the modules have been flashed do I need to code each one in NCS with a blank MAN file?
  4. Is the cable I have sufficient to flash (see picture)? It's worked flawlessly so far for diags and coding
  5. How long would it take to flash each of these modules?
  6. I don't access to a 70 AMP power supply. I can get my hands on a 20 AMP battery charger. Would that (and a strong fully charged battery work ok)? Or jump leads to a another car which is kept running?
  7. Any other modules that should be updated from my list below?
  8. Am I mad for even considering this? Will I end up sitting in my car crying as the dashboard does a Christmas tree impression?

Appreciate any input you have!!
UW

-----------------------------------------------------------------
ADR Gen. name JobStatus 92 VIRTSG92 ERROR_ECU_SERVICE_NOT_SUPPORTED
-----------------------------------------------------------------
ADR Gen. name JobStatus ZB No. VIN No. Date
00 ZGM OKAY 9118729 ÿÿÿÿÿÿÿ 30.11.2005
01 SIM/SGM OKAY 9118749 ÿÿÿÿÿÿÿ 13.03.2006
02 SZL OKAY 9115162 B721564 17.03.2006
12 DME/DDE OKAY 7563568 B721564 23.03.2006
17 EKP OKAY 7180427 B721564 18.03.2006
18 EGS OKAY 7564226 B721564 23.03.2006
29 DSC OKAY 6775732 0000000 13.08.2005
36 TEL/MULF OKAY 9224673 ÿÿÿÿÿÿÿ 04.02.2010
40 CAS OKAY 6943791 0000000 06.12.2005
41 DWA OKAY 6965588 B721564 21.02.2006
44 SHD/MDS OKAY 6955926 B721564 08.07.2004
45 RLS OKAY 6980019 B721564 04.08.2005
60 KOMBI OKAY 6983166 B721564 15.03.2006
62 MOSTGW OKAY 9117539 ÿÿÿÿÿÿÿ 07.03.2006
63 MMI/CCC OKAY 9117517 0000000 07.03.2006
64 PDC OKAY 6978232 B721564 17.03.2005
65 BZM/SZM OKAY 6988878 ÿÿÿÿÿÿÿ 10.03.2006
67 ZBE OKAY 6944884 ÿÿÿÿÿÿÿ 17.01.2006
70 LM OKAY 9112630 ÿÿÿÿÿÿÿ 15.03.2006
72 KBM OKAY 9114447 0000000 20.10.2005
73 CID OKAY 6989395 ÿÿÿÿÿÿÿ 30.11.2004
78 KLIMA OKAY 6988504 ÿÿÿÿÿÿÿ 13.03.2006
90 VIRTSG90 OKAY 9117540 ÿÿÿÿÿÿÿ 07.03.2006
91 VIRTSG91 OKAY 9117521 0000000 07.03.2006
================================================== ===============

cable.jpg
 
1 - 1 of 1 Posts
Top