BMW Forums : BimmerForums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I purchased a bmw 6 series e63 2004 about 2 months ago. The guy told me the headunit needed coading as no sound would come out of the speakers but everything else worked fine. A guy a friend of mine knows works for bmw, he tried to code the unit in the car but had no joy! He told me the CCC needed replacing & gave me a part number.

I removed the CCC that came in the car & it was the completely wrong unit for my car thats why it wouldnt code. A bit of searching found £1350 from bmw direct, £600 online from germany & i found one coded on ebay for £360. I got the one from ebay with the exact part number i needed. I pluged it all in & i now have sounds. But the screen wasnt central, so i got hold of the guy on ebay & he thinks who ever changed the ccc has also changed the screen as my car is ment to have the wider screen. The controller is also thinking its being spun left so to navigate thorough the menu is almost impossible 😞 he also thinks the controller has been changed. I can get the screen & controller for another £50 & im confident i can fit it my self. But the fm radio skips like a cd when driving or revving. Its fine on idle but as soon as you move or rev it jumps like a skipping cd 😞 i will post a video.

I dont want to spend another £50 for the screen & controller just for it to skip consistently on raido or cd as ita unbearable 😞 would the screen or controller be a reason why its skipping? I thought maybe the amp in the boot needs replacing but as it works fine in nutral or idle i dont think it is. Maybe a loose connection? Maybe a power surge from the battery. Any help would be appreciated as im starting to lose all hope with getting it sorted 😞 sorry for bad grammer & spelling english wasnt my hottest topic at school lol
 
1 - 1 of 1 Posts
Top