BMW Forums : BimmerForums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
479 Posts
Discussion Starter #1
Hi
It's been a whike since I last posted here. My car had timing chain break on me about 5 months ago and had quite a lot of work done on her after she went into limp mode after drive train error and the garage were unable to turn of the engine check light after doing the work
Anyway since then I have only done short cold journeys and now the drive train drive moderately warning came back on when I went above 45mph and limp mode. Turned engine off and back on and after a few days the same problem again.
I read the codes using a BMW specific reader a C110+ BMW SCANNER
and I'm getting
258300 exhaust back pressure sensor -signsl too high
250B0D exhaust back pressure sensor before particle filter signal: short circuit
244C00 charge pressure control, control deviation , boost pressure too low/ positive difference .
Then I have the following options:
Do you want to reset adaptation value for rail pressure control valve?
Do you want to reset the adaptation value for exhaust back pressure sensor before exhaust turbo charger

Basically what would happen if I reset the adaptation values. I'm suspecting it could be from the work I had done because the garage were unable to clear the engine light which I can but then it cones back on when drive train error pops up.
Any help and advise will be greatly appreciated
 

·
Registered
Joined
·
479 Posts
Discussion Starter #2
Hi
It's been a whike since I last posted here. My car had timing chain break on me about 5 months ago and had quite a lot of work done on her after she went into limp mode after drive train error and the garage were unable to turn of the engine check light after doing the work
Anyway since then I have only done short cold journeys and now the drive train drive moderately warning came back on when I went above 45mph and limp mode. Turned engine off and back on and after a few days the same problem again.
I read the codes using a BMW specific reader a C110+ BMW SCANNER
and I'm getting
258300 exhaust back pressure sensor -signsl too high
250B0D exhaust back pressure sensor before particle filter signal: short circuit
244C00 charge pressure control, control deviation , boost pressure too low/ positive difference .
Then I have the following options:
Do you want to reset adaptation value for rail pressure control valve?
Do you want to reset the adaptation value for exhaust back pressure sensor before exhaust turbo charger

Basically what would happen if I reset the adaptation values. I'm suspecting it could be from the work I had done because the garage were unable to clear the engine light which I can but then it cones back on when drive train error pops up.
Any help and advise will be greatly appreciated
Due to my cold short journeys I suspect possible dpf but I've probably only done about 1000 miles since having the work done so as I want to try and reset the adaptation value.
I forgot to mention it is a 2010 525d (3.0 litre n57 engine)
 
1 - 2 of 2 Posts
Top