BMW Forums : BimmerForums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
Hi all,

I have a bit of a problem with low MPG at the moment, I recently changed my air filter, but the car has a bit of a history of lower MPG values, one of the comments when I had my glow plugs changed a few months ago was an air intake issue which could cause loss of power and mgp performance.

Recently changed my air filter last weekend, and it just doesnt feel right, when pulling on the motorway you can see that the MPG needle on the dash cluster drops quite low when I boot it, and it seems like im sticking fuel in, but its going through fuel quite quckly.

One thing that I need to do and I am not sure if this is the root cause, you know where the air intake comes in? you have a meshed tube, well this is seriously old and the seals have gone on both ends, so at the moment having to ductape it, but there isnt a good seal here. Could this be causing less air to come in thus it not getting a good air/fuel mixture?


http://rmpumper.weebly.com/uploads/2/3/9/0/23904416/564785_orig.jpg


could this be an issue? or am I going to be spending £30-£40 on something which may not rectify the issue per say.

The air filter is new in, I cant see that being the issue, or is it likely to be something else?

Appriciate any help :)
 

·
Registered
Joined
·
137 Posts
Running temperature checked?
Thats just as likely to affect MPG if you have fitted a standard filter (assuming its not a K&N or something daft?)
 

·
Registered
Joined
·
119 Posts
Discussion Starter #3
The engine temp? Is there an easy way to read this as there is nothing on displays or obc.

My engine does get very warm after a drive, to the point i am concerned, and I am not sure if my radiator fan is kicking in, is there an easy way to test/rule this out?

Filter is just a standard Mann filter
 

·
Registered
Joined
·
460 Posts
Sounds like a Maf sensor its a basic function on a diesel. Disconnect it and see if it if runs better. The EML light will come on but you will know then thats the problem.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #5
I will try the maf disconnect as a test to see if it drives better with it disconnected.


Should the rad fan be kicking in when it gets to a certain temp? how can I check?
 

·
Registered
Joined
·
137 Posts
I will try the maf disconnect as a test to see if it drives better with it disconnected.


Should the rad fan be kicking in when it gets to a certain temp? how can I check?
Use the search option on here or youtube for the hidden menus, its proper easy and a 'click' away pal...
 

·
Registered
Joined
·
119 Posts
Discussion Starter #7
Cool will have a look for hidden menus

Disconnected the maf sensor , didn't come up with management light which it did when I was changing the air filter.

Drove pretty much the same

I'm worried about my engine temp though and the fact I don't think the fan is kicking in
 

·
Registered
Joined
·
137 Posts
well if disconnecting your maf made no difference its knackered so it will need cleaning and probably replacing. Take it from there.

Ref the cooling fan, you need to check the temp first on the hidden menu as it should stabilise around 90 degrees c. If the cooling systems working well, its unlikley for the fan to start unless its oooober hot, unlikely in the UK :thumbsup
 

·
Registered
Joined
·
119 Posts
Discussion Starter #9
Thanks I will check out cleaning or replacing the MAF sensor, hopefully its just a clean.


I will also look out for the hidden menu, will let you know how it goes, apologies if it takes a bit
 
1 - 9 of 9 Posts
Top