BMW Forums : BimmerForums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Just thought I would ask the following as I cannot remember coming across this before:-

I have a 2015 640d - Mileage at 24k. This week I have experienced that when I adjust the Climate control between 16-27.5C, the air being blown out is the same throughout (A/C is OFF, Centre Hot/Cold wheel between front vents set in the middle). As soon as it sets to 28C then hot air blasts out. Anyone else come across this?

Also - not sure of this affects the above, but 2 months earlier the Dealer had taken out the dash completely to fix a previous issue.

I have extended warranty on the car with the same dealer, and booked it in for a check on the above issue in 3 weeks time, but would be grateful for any advice to ensure I am fully informed before the appointment.

Cheers for your help.
 

·
Registered
Joined
·
4 Posts
4 Series GC Broken Climate Control

I have a similar issue, I have a 2016 4 Series GC with 28K on the clock.

I set the climate control i to 22c the fan comes on and heats the car up eventually but then does not cut off it just pumps hot air, I turn the temp down to 16 and nothing it keeps pumping out hot air.

This has been reported to BMW dealership they reset the climate control and recalibrated, which seemed to work for 2 days but then it went back to its old ways.

I have had the car for just over two months, I reported the fault within 2 weeks and had to wait 2 months for it to be looked at.

Now I am down the rejecting the car route but having issues with the dealership saying it is not a fault.

I have been told to take the car in so they can determine if there is a fault again, it is their route to cover themselves so they can reject me returning the car.

Good luck let me know how you do and it you actually get it fixed, what it is that caused it?
 

·
Super Moderator
Joined
·
3,412 Posts
The OP's fault sounds like the cabin temperatures sensor - this was exactly the same problem on the earlier models in that the NTC sensor buried behind the panel failed - or the small fan that sampled air from the cabin gave up.

On the 6-Series, the air sampling is via the small grille between the front and rear defrost button which directs cabin air to the sensor. If the fan fails the temperature control usually seems to work except that the cabin temperature is very poorly controlled - it gets too hot, and then it gets too cold and never manages to hit a happy medium.

When the sensor fails it is much like the OP describes, the control usually only makes a difference at the very extreme of settings.

The sensible way forward is to use diagnostics to see what the IHKA thinks the cabin temperature is.
 

·
Registered
Joined
·
58 Posts
Hi Timm,

This sounds very similar to the other thread that I have at the moment for my air con issues;

But my cabin temp is accurate. I'd appreciate if you could have a look over there, as about to post loads of details from my testing today.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #5 ·
On the 6-Series, the air sampling is via the small grille between the front and rear defrost button which directs cabin air to the sensor. If the fan fails the temperature control usually seems to work except that the cabin temperature is very poorly controlled - it gets too hot, and then it gets too cold and never manages to hit a happy medium.

When the sensor fails it is much like the OP describes, the control usually only makes a difference at the very extreme of settings.

The sensible way forward is to use diagnostics to see what the IHKA thinks the cabin temperature is.
I could not see this sampling grille on my 6GC.

I had to postpone my dealer appointment until next month, but have been trying to test under different scenarios. It was suggested on another forum that a Sunny day could cause conflicts with the HVAC system requesting heat.

So, on a cloudy day, outside temp 14C, with the centre dash wheel on Red, AC ON, as I increased the temp from 20-27.5 there was no heated air coming out of the vents, but once again at 28C hot air blasts through.


AC function works fine. Just seems the call for heat is being ignored.

Where could the fault lie?
 
1 - 6 of 6 Posts
Top