BMW Forums : BimmerForums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have owned my 535d for almost a year now fault free. A while after my last service I was accelerating hard and got an engine light. This happened one or two more times and then I was accelerating and my engine cut out completely turned off. I am going replacing the fuel filter again just incase its faulty but can anyone point me in a direction to look.
 

·
Registered
Joined
·
1,551 Posts
Could be several possibilities LPFP,HPFP,rail sensor,injectors leaking too much back causing rail pressure to drop.
You are going to need some more diagnostics,fuel filter is cheap and easy to change but I suspect it won’t be the issue.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Could be several possibilities LPFP,HPFP,rail sensor,injectors leaking too much back causing rail pressure to drop.
You are going to need some more diagnostics,fuel filter is cheap and easy to change but I suspect it won’t be the issue.
What kind of values should i expect from the hpfp and lpfp and the rail sensor. Is there a good way of testing the hpfp and lpfp or will they have to be taken to a specialist I dont think my diagnostic can read them im not too sure though
 

·
Registered
Joined
·
4,830 Posts
.https://www.e90post.com/forums/showthread.php?t=1663082 also this one
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
Ran diagnostics on the car at idle injectors at 300 bar then at 4000rpm they were roughly 1300 bar now I reas that theyre meant to be 1600 bar but is that at 5000rpm with limiter mapped out or at 4000rpm with soft limiter? Couldnt get fault to appear under hard acceleration around town and revving high fault only seems to occur at around 100kmh when driving the accelerating to overtaking people.
 
1 - 8 of 8 Posts
Top