BMW Forums : BimmerForums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
HI HAVING A LITTLE PROBLEM WITH MY CAR, IT HAS A SLIGHT MISS ON LOW REVS THEN IS FINE REST OF WAY THROUGH REV RANGE, THINKING IT COULD BE THROTTLE POSITION SENSOR BUT NOT SURE?,ALSO ON YOUR ODOMETER DISPLAY I CAN BRING UP SOME TEST CODES CAN YOU TELL ME IF A FAULT CAN BE READ HERE AND IF SO HOW I READ THEM, CHEERS JON:cool:cool:cool
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
Thanks no not properly and you could be right, did think this could be the problem as there was a bit of info in my cars history that it had a slight airleak on inlet manifold change over flap not sure wha bit that is??? And no recall of it been fixed thanks for the help
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
It seems to be using the same really i mean as only owned it 3 months and not noticed a change, but there not the best on fuel but who knows if i am getting under average, have just put a new maf sensor on and its worse but worked better previous unplugged. Is it worth disconnecting the battery so the ecu re-learns things!?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #6 ·
Fault seems to be not as bad cleaned plugs up engine was running rich due to had to replace maf sensor so disconnected it, so presume thats why it ran rich. Going in for diagnostic so will see what the outcome is!
 

·
Registered
Joined
·
20,393 Posts
You need to get the fault codes read, then post them up here and we can help you further.

There's no way of reading the fault codes through the dash, only way is with a scanner. I'd suspect a air leak or a cam sensor
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top