BMW Forums : BimmerForums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 · (Edited)
Hi all.
I treated myself to what seemed a great car about ten days ago, its a 530 D SE 2002 year , i paid 4.5k for it and it looked a dream but so far its been a nightmare.
It worked for two days without missing a beat, I put it on the ferry to France to drive down to Toulouse where I work, that took four days with two major breakdowns due to the car not starting . so far with breakdown trucks to take me off the motorways ,hotel bills,330 euro bill for a new crankshaft sensor and new camshaft sensor that failed to improve the starting problem I have lost about 1200 quid.
the car has only 83000 miles on the clock and seems perfect once it is running, giving about 43 to the gallon,. so when its working I just love it,

From what I have read on this forum and others is that the problem is most likely to be the pre supply fuel pump or a leaky injector, but one thing that I am not sure about is that the "PRE HEATING" light does not always appear even when its very cold first thing in the morning, if it does come on it is a good sign that tha car is about to start and it does !
If the car has failed to start you can try for an age but it will just refuse,
its like you have one chance to get it going and if that fails you may as well call it a day.
Then go back the next day and it may fire up and run like a dream, just to tease you.
So what I am asking is if the fuel pressure is too low for the car to start will the "PRE HEATING" light fail to show.
I have not seen anyone else mention this, so perhaps my problem is not fuel or injector related, but then again I have had the engine very hot on the motorway and stopped for just twenty mins or so and the car has failed.

I have put the car in a local garage close to where I live now and the mechanic has told me that the crankshft sensor is new but the camshaft sensor has not been replaced as my BMW garage bill shows .
I just hope this guy can fix it for me .any clues would be great then I can pass them on to him. cheers.
 

·
Registered
Joined
·
470 Posts
The pre heat light should always come on when you switch on the ignition it should then go out quite quickly (maybe on a tad longer if cold - a second perhaps) and you can then start the car - if it does not come on then this definatley will need looking at - as this light refers to glow plugs which heat and allow initial combustion for the engine to fire up and get going .. hope you get it sorted....
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
Thank MTEC B

Thanks for the help . its strange cos the car has been in the local mechs hands all day without a fault, he is monitoring fuel pressure etc on a very sweet looking hand held device, pre supply fuel pressure is about 2.7 bar on tick over and about 3.4 with ignition on without running.
I think that is a bit low but I am not sure. Oh and the pre heating indicator only worked on the first start today so that is still a worry
The cam sensor was in fact new and the local guy was wrong , there was a manufacturing date printed on it, so I had to eat some humble pie with the BMW garage. they were fine, good job I didnt go in all guns blazing.
But it looked pretty dirty so I dont feel too bad.
cheers again
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
530D SE year 2002 preheater and fuel pump

can anyone tell me where to find the cold start pre heater timer relay and the pre supply fuel pump relay on my 530 D .
I want to illiminate them before lashing out on a new pump and pre heater timer. it quite a saga now and costing more than I had expected to get my car back on the road.
also does anyone know a good company to buy the pump and preheater timer
from
thank you in advance
Chris
 

·
Registered
Joined
·
23 Posts
I'm not sure if it's different on the E60, but my pre-heat indicator very rarely comes on. Only if the weather is very cold and the car has been stood for some time.

I actually queried this on here just after buying the car, because I couldn't figure out where the pre-heat light was.

I just wonder if you're barking up the wrong tree with that?

Good luck.
 

·
Registered
Joined
·
46 Posts
iv had the same sort of problem recently with my e46 320td. it was the pressure relief valve was thinkin that it was over pressure and letting all the pressure out so wudnt start. try and get a diagnostics check and see if a fault code. hope this helps .
i no its not the same engine or series but might give an indication as to what it could be.
 

·
Registered
Joined
·
20,393 Posts
can anyone tell me where to find the cold start pre heater timer relay and the pre supply fuel pump relay on my 530 D .
I want to illiminate them before lashing out on a new pump and pre heater timer. it quite a saga now and costing more than I had expected to get my car back on the road.
also does anyone know a good company to buy the pump and preheater timer
from
thank you in advance
Chris
Will see if I can find out at work and posty back :thumbsup
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top