BMW Forums : BimmerForums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Yesterday a mile from home, I heard a loud bang from the front of the car. No warning lights came on so when I returned home, I hear a loud hissing from the front nearside of the engine, but no apparent leak of fluid or steam etc. However, the air con is not working. Fan is ok, but just pushing through ambient temperature. Car is under warranty so BMW recovery due tomorrow. I’ve checked under the car and nothing untoward is visible with the plastic panels intact.
I assume the air compressor has failed but the noise was like a grenade going off...
Just wondering if anyone has had this issue in the past.

Thanks
 

·
Registered
Joined
·
335 Posts
Not sure. Maybe a pipe burst or popped off if you're lucky. Perhaps even the condensor splitting. Both probably easier/cheaper tha a new compressor. If the system has lost all gas though you must get a new receiver dryer on top of whatever went pop, otherwise the system will never perform perfectly again - the moisture absorbed by the old dryer from the system being open for a few hours or more will damage it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Diagnosis confirmed today. A wheel nut from another car has pierced the air con condenser. No warranty claim so £1k to replace and regas the unit.
At least whilst it’s in they are going to drill a hole underneath to allow the water to escape which is a well documented issue with these cars.
 
1 - 3 of 3 Posts
Top