BMW Forums : BimmerForums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi chaps and chapess's!!

Im hoping you could solve a mystery for me! I have a BMW E36 318 93/L that will not start when hot. I have replaced the ECU (im aware some get water in), the crankshaft sensor and the coil pack.

It will start ok when cold first thing in the morning, once warmed up it will not restart, I have checked for a spark and nothing. If I keep cranking it over until the battery has almost ran flat it sparks and fires up!?! So after a bit of a run I have to put all the lights on, wipers, blower etc to drain the battery to get it to start!! Once going it runs like a dream!

Any ideas anyone?? Im thinking along the lines of a faulty relay possibly???
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I took it to a mates garage and he put his diagnostic on there and it came back saying internal fault on ecu or poor earth. I have cleaned every earth I could see in the engine bay and replaced the ECU. Will try swapping over the relay and see what happens. Thanks for the reply!1
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Now thats a pretty usefull site i'll bookmark that one.... thanks for sending that!! Any of you guys ever heard of a battery thats to powerfull for a car?? My friend swears blind its this but I cant see as I have always up graded my previous batterys?? Its got an 075 on it atr the moment and the cca is 570!!
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top